Zorin 15.3 doesn't boot with a separate data storage HDD

Hi everyone!

Zorin OS 15.3 is installed on an SSD. I installed a HDD in my PC as a data storage device and formatted it to Ext4 and earlier I've tried formatting it to FAT. When I turn on the PC I go into the bios and select the option to boot from the Zorin OS SSD. After hitting enter, I get a blank screen with a flashing underscore and nothing happens. I get this issue no matter if I format the HDD to FAT or Ext4. When I disconnect the HDD, Zorin OS boots just fine from the SSD.
What am I doing wrong?

Thank you for your help in advance.

You probably need to go into your bios settings and change the boot order. Depending on your bios you may need to look in the advanced settings area. You want your bios to look at the SSD before the HDD so it can see the boot file of the SSD.

3 Likes

I tinkered with the BIOS/UEFI. All drives are disabled in the boot order except the one which has Zorin OS installed.
Now the OS boots, and Zorin recognizes the data storage HDD (formatted Ext4) in the "Files" app after mounting it, but I can't create new folders on the HDD so basically I can't use it.

EDIT

When I formatted it as Ext4 and set it up as an extended partition I was able to edit the drive in Linux.

I decide I want to use it as a data storage drive for use with Linux and Windows.
As I understand it formatting it as FAT32 will make it recognizable for Linux and Windows, but the file size is limited to 4Gb. NTFS is not limit to 4Gb in size but it's not recognized by Linux, right?
So if I want to use the HDD with Windows and Linux I can only format it as FAT32?

I am sure there is a way around that as I have an external drive I use for storage and I can write to it. I don't know enough to tell you what to try but maybe Aravisian or someone else can help with that. Sometimes the files manager is the problem. You might try the search feature on this forum by searching for " unable to write to a different drive". I'll also look for an answer for you.

1 Like

Here is one of the results I got when I did a search on this forum. There are several others you can try if this doesn't work.

Have you changed ownership of the drive?

No I haven't but I've solved the issues.

Here's how:

  1. I only enabled the SSD containing the OS to be bootable, all other drives options are disabled in the boot order.
  2. I created a single extended partition on the HDD and formatted it as "Linux". Does anybody know what a "Linux" format stands for? Ext4 maybe?

I can mount the HDD, I can read and write it. All is well.

Thank you all so much for taking the time to help my with this issue. I appreciate it.

1 Like