Zorin 15.3 not recognizing 4k HDMI Monitor

Anyone knows for latest Zorin OS 15.3 Core if my laptop is fully compatible, especially HDMI output. this screenshot is from OpenSuse which it is compatible, but I dont like using Opensuse.

Notebook Asus Gaming TUF A17, FA706II-H7097,
17.3" FHD IPS 120Hz, AMD Ryzen 7 4800H up to
4.2GHz, 16GB DDR4, 512GB NVMe SSD + 1TB
HDD, NVIDIA GeForce GTX1650Ti 4GB,

As with all earlier releases, my advice as per earlier Zorin main page advice and on their FAQ pages would be to download the .iso (either Core or Lite from here:
https://sourceforge.net/projects/zorin-os/files/15/
and create bootable media and run it off the bootable media to see if everything works as it should - including Fn keys, touchpad etc. Only after thorough testing in Live Mode can help you make the decision whether to install or not.
You may want to look at the Unofficial Manual I created for Zorin 15 Core (I never got round to doing one for Lite):

Thanks Swarf for the suggestion, but unfortunately Zorin doesn’t run on my rig.
Trying Zorin I have to say that Zorin from USB somehow works better from Open Suse which is fully compatible and Zorin is faster than Ubuntu when I have tried Ubuntu.
the issue I have is that HDMI output doesnt work and my huge 4k monitor is useless :frowning:

Didn’t StarTrekker have the same issues with Large screen HDMI TV? I cannot recall how he solved it. Will shoot him a message.

2 Likes

The only issue I have ever had with my Acer notebook’s HDMI port, is that it refused to serve a 4K resolution. According to the Nvidia website, my Gforce 640M GPU should support the 4K resolution, but all attempts to achieve that resolution failed.

Not only would the OS not show any supporting 4K resolution to change in Display, but trying to use the terminal to force the computer to display 4K, resulted in losing signal to the TV all together, requiring a reboot to get going again.

The problem is, back in 2012, manufacturers didn’t think people would be able to adopt 4K screens yet, as most people were still using 720P and 1080P monitors and TV’s at that time. So Acer just cheeped out and slapped a port on the board with lesser support.

I even went as far as, to buy an USB 3.0 to HDMI converter box with 4K support. Guess what? The OS still would not give me 4K support. So after returning said device, I just gave up at that point, and conceded that I would not win the battle, as all odds are against me. I just need a new PC.

The part that really sucks about not having 4K support, is that any production work that I want to do, weather it be 4K video editing, or 8K photo editing, all of that is harder to do on a 1080P resolution, its quite limiting! 4K is where its at for a reason fellas.

Now, there is technically another issue that I’ve had, but its not a game breaker, and is easy to deal with. If I boot the notebook with the lid closed, as soon as I reach the login screen, the notebook will suspend and cut signal to the TV screen. Yes, even though I set the OS to ignore the lid switch in every possible place one can think of, the OS does not respect my choice at the login screen.

I have to keep the lid opened during the boot process. Once I have logged in, then I can close the lid, and then the OS will begin my screen saver with a lock screen. All I have to do is enter my password one last time after logging in, and then the computer will ignore the lid switch from that point forth. But it will always reset after a computer restart.

Some people might consider that an annoyance to great to deal with. But, I have struggled all my life, with real problems, real issues, so I can forgive that little annoyance. But not having 4K support, that I cannot and will not forgive.

2 Likes

I agree, I need 4k HDMI output. How com OpenSuse can make it work. It is all LInux kernel as far as I understand?
Such a shame as I liked Zorin at first glance and use. Not a single glitch performance from ordinary USB, l cant imagine how good must be it with new fast NVMe drive.

Interesting articles here:

1 Like

cool…thanks mate
Do you think Zorin would work better in setting up 4k hdmi, or shall I try to setup it first on USB stick?
As at the moment Open suse is perfect in that sense, but I dont like using it, I prefer ubuntu, or even better Zorin after I tried USB only.

Thats another thing my computer doesn’t have support for due to its age. Its funny, cause if you watch Linus Tech Tips, you pick up on how Linus makes it sound like NVME drives have been around forever, when in reality, they are actually a new thing that haven’t been around for very long. He installs them in every computer he builds, but doesn’t like to admit that they cost 2-times more then standard SATA SSD drives lol.

Just seein how Zorin works slick and fast makes me do full install, but is really silly when I cant use two screens.

Zooooorin people make …make it work

Maybe this will help?
How To Do Dual Monitor Setup

1 Like

Wil try for sure as I really want to use Zorin…Although I have a inkling that it will not work as my 4k monitor is not recognised at all, even on my built in laptop screen I can not change resolution which smells fishy to me.

Hopefully, if you do the full installation, a solution iwll be more easily applied
https://www.dell.com/community/Precision-Mobile-Workstations/External-Monitor-not-working-Ubuntu-nvidia/td-p/6241315

1 Like

Thanks but I dont know how to edit this file? Can you help please?

Open the file in your favorite editor (vim, nano, gedit, etc.).

sudo nano /lib/modprobe.d/nvidia-kms.conf

And comment out the the nvidia-drm modeset option.

This file was generated by nvidia-prime

Set value to 0 to disable modesetting

options nvidia-drm modeset=1

Hope this also helps you and many others!

When you talk to a soldier or an air traffic controller, they often forget to not slip into using Jargon to describe what they mean.
Computer users do that too. But, this teaches the jargon, as well.
To “comment out a line” is to place a Hashtag in front of it. In this coding, the hashtag is a note to the system to ignore the line that follows the hashtag.

Open a terminal with ctrl+alt+t
Then paste into it the command

sudo nano /lib/modprobe.d/nvidia-kms.conf

sudo is SuperUserDO (as in ‘do this’). Nano is the terminal emulators text editor. /lib/modprobed./nvidia-kms.conf is the path to the file you are about to edit.
Now that the file is open in the Terminal, use your tab key or arrow keys to move the cursor.
Look for a line that looks like this:

nvidia-drm modeset=1

When you find such lines, place a hashtag at the very front to tell the system to ignore those instructions so that they look like this:

#nvidia-drm modeset=1

1 Like

Thanks, I can do up to here. it seems that I have opened new file with this specified name, as it is empty in my opinion.

btw I have installed Mate as I read somewhere that Ubuntu Mate may provide me with HdMI output

Thank you, kind regards

I have tried this procedure and I dont see HiDPI option at all.

I agree with your opinion. :slight_smile:
It looks like the file does not exist and in so doing, you would create the file.
I, too, am using a version of Mate: Cinnamon Desktop installed on Zorin.
However, I have never used Nvidia Graphics card.
I am using Two Monitors and it was three monitors prior- until one monitors Power Input Card (PCI Board) went out. I have never had any problems and Zorin always picks up my output to the connected monitor- including the Living Room T.V. and the big huge screen TV in the shop.
I can tell you that the problem is not Zorin, it is Nvidia. You can watch youtube videos of Linus Torvalds cussing Nvidia out because as soon as they patch a kernel, Nvidia goes and changes something.
Some people have more luck and some Distros have more luck and it’s very hard to find some Guru that really understands why it works (even if temporarily) on one distro with all the same stuff as another distro on the same machine, but not with that other distro.

On Mate Tweak, you may need Compiz, I am not sure.

1 Like

I have tried and second 4k monitor works beautifully. without any graphics problems, but I prefer Zorin, seems faster and more stable and simple to use
Not sure what I can do. Maybe your cinamon? Or maybe different desktop environment on OpenSuse but then will be slow anyway. Btw can you open this file in question /lib/modprobe.d/nvidia-kms.conf

I cannot because I do not have that file either since I do not use Nvidia. I do wonder if your Nvidia card is being recognized, at all.
If it is not, I wonder if we can jar the system into seeing it.