Zorin 16 keeps on locking the screen everytime

I've disabled automatic suspend, Dim screen when inactive, and set blank screen to never. What could be the problem?

Hi, and welcome to the forums.

Just to clarify, this happens when you close the lid on your laptop? Or is it at some time intervals when you walk away from the computer?

Also, are you using the Pro Core or Pro Lite version of ZorinOS? If you are on Core, which uses the Gnome desktop environment, then you can try following this thread:

1 Like

In terminal, try

xset -s 0 0

If that does not work, try

xset -dpms

If that works, you can set it permanently by elevating to root

sudo -i

Navigate to /usr/share/x11/xorg.conf.d and create a new file. Name it
Copy and paste the below into it:

# Disable DPMS
Section "Extensions"
        Option "DPMS" "Disable"
Section "ServerFlags"
        Option "BlankTime" "0"

Save and close.

Am using Zorin 16 Pro, and it happens while am using my PC not necessarily when i close the lid. It is so annoying especially when am coding with Vscode

By this do you mean that it's happening more often while you're using VSCode, or it's just more annoying because you're in the middle of some work? Which leads to another interesting question: does this happen while you're using the computer?

Have you tried any of the suggestions from the previous posts?

1 Like

This is also a little concerning. I can see the lockscreen being activated while watching a video or playing media like music. Due to a lack of mouse movement or keypresses.
But actively coding? Many of us know full well that is constant mouse clicks and movement and constant keypresses.

I would also add another suggestion: Thoroughly clean your keyboard. Blow any dust and debris out from under the keys - check for any sticking or gummy keys.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.