Zorin 16 lite boot options issue

i'm having an issue with zorin 16 lite and booting into a live cloned os of my personalized z16 lite.

i've built z16 lite with some customization and i used clonezilla to clone that to a usb drive so i can copy to my fleet of computers. i'm having no trouble doing this. it's been smooth cloning from the computer to the usb drive and from the usb drive to the computer. i've tested on a handful of computers and no issues with this part of the process. but i ran into a problem when i tried to boot into my live usb clone of z16 lite to run updates and make a few changes on one of the computers i had upgraded to z16 lite from z15.3 lite. and i've been running this process with 15.3 lite for a few years and never had this issue.

list out what i've tested:

below "computer" is the same computer that i've run this test maybe 10 times - minisforum n40 (not their newer n4020 model). each computer was wiped after each test and tried again. and i've also used numerous computers of the same model and a few other models to run the tests twice. all the computers are pentinum or celeron fanless pcs. and i when i talk about "booting into" i mean from the computers bios/uefi menu not grub. this problem happened in all the computers i tested.

i have verified that the usb ports are working fine. i know the usb clones are working fine. i know the usb installers are working fine. and i know the live clonezilla usb drive is working fine.

computer with 15.3 lite installed - when i plug in my clone to live boot into it, it boots right up whether it's a clone of 15.3 lite or 16 lite. so i'm able to make changes in my live clone.

computer with 16 lite installed - when i plug in the clone of 15.3 lite it boots right to my live clone. when i plug in the clone of 16 lite, it does not see it in the boot menu.

computer with xubuntu 20.04.3 installed - when i plug in my clone to live boot into it, it boots right up whether it's a clone of 15.3 lite or 16 lite. so i'm able to make changes in my live clone. i wanted to run this test to see if it was something with the base ubuntu 20 having this problem. it didn't, xubuntu 20 let me boot right into my live usb clone os.

so the tests with zorin were tested with my full clone copied to the hard drive of both z15 and z16, so all my tweaks were installed on the computer. but i also ran these tests with a clean install of both versions of zorin from the .iso installer, so it was a complete default build of zorin and the same situations happened. z16 lite was the only one that wouldn't let me boot into my live version of just my cloned usb of z16 lite.

i've been doing the clone process with clonezilla on zorin 15 lite for many years, but also a few different versions of ubuntu and other versions for years before that. i've never had this problem of not being able to boot into my live cloned os from the computer boot menu... unless it was a bad drive or bad usb port or a bad .iso. and all of those things i have verified are working fine in these tests. i've completely isolated this issue to be related to z16 lite installed on my computers, whether it's my cloned z16 or a clean copy of z16 installed.

so with all the factors it seems like z16 lite is the problem. i don't know if it's how it writes to grub or something in the os partition. but something is going on that i can't replicate unless z16 lite is installed.

If I followed along correctly, it sounds like you were attempting to install Zorin OS 16 LITE, on seriously old 32-bit machines, correct?

Simple answer, Zorin OS 16, either Core, or LITE, only supports 64-bit CPU's. All future distributions, will be the same way.

The newest OS that you can install on those old computers, is Zorin OS 15.3 LITE.

This is happening because Linux support for 32-bit CPU's is being dropped, as most people have 64-bit machines now days, and its just far too much work for developers, to continue supporting 32-bit hardware.

Hope this addresses some confusion, and as a result, helps you with your solution.

1 Like

that is incorrect. they are not 32 bit machines or old. they are 2020 models and 64 bit. i haven't touched a 32bit os or app in probably 5 years. i didn't use 15.3 32b either. all 64 bit.

also, it was tested on a few other fanless celerons from mid last year. one was gk41 which as the J4125 processor. same issues.

also. ran the test with xubuntu 20.04.3, which is what z16 lite is based on and that worked perfectly in the workflow.

Have you tried running os-prober?

i haven't. but i'll look into it. thanks.

they say they're disabling it by default in the upcoming version of ubuntu/grub 2.06. i wonder if the zorin guys are using grub 2.06 for z16 lite and that's where this issue is coming from.

Zorin OS 16 Lite is using Grub 2.04.

grub-install -V

it's funny that i had just screen grabbed an article about ubuntu 22 last week and made note of the new grub, thinking it might be a problem in the future. but i didn't put together that it could be an issue for what i was running into, because z16 wasn't based on ubuntu 22. but it seems like going down this road might be a solution, maybe they made changes in grub2.04. i'm working on it today. thanks you.

os-prober is probing:
/dev/sda2:Zorin OS 16 (16):zorin:linux
so the os is readable on the usb stick. but i have really gotten into the weeds in this one. i adjusted a setting in the grub file so i would get time to hit the option to go into the uefi on the grub menu on my xubuntu 20 test live os usb and and when i hit sudo update-grub now that doesn't let me see my live usb os anymore. still can boot into clonezilla and the os installer usb, but not the live os that i made in clonezilla. and i thought clonezilla might be an issue. so i tried the newest version. same thing. then i tried the version that i use without fail in the z15 lite system and nothing was able to bring back booting to live usb. i've been all through the bios/uefi menu, resetting to defaults and trying it. making a few changes that i had before and trying it. nothing. i don't know if once i hit update grub if it went from something more stable i was using to the v2.04, which z16 lite uses. i checked the version on xubuntu and it was v2.04 but i just don't know if that's what it started at when it was working. i have to go back and do a clean install and see what version it starts with. same with z15 lite. after doing the same to my z16 lite grub - changing to show the menu - once i hit update grub, now the computer with z16 on it can't see any live os usb drive. but will see the clonezilla and the usb installer. i've totally made things worse.

This may seem like a goofy question but... Have you tried a different USB stick?
Also, (perhaps on a different USB stick) have you tried using Ventoy? Install Ventoy, then just drag and drop your cloned .iso onto it; it will create the bootbale media for you.

Also try another USB port.

5 sticks. 2 usb ports. 4 different computers. probably 20 wipes and start overs from the usb installer. i haven't tried ventoy. but i'll look into that. clonezilla has been reliable for years. and the usb that i'm making in clonezilla can be cloned on to the computer. the problem is if i want to just boot into the live usb os (to do updates or make a tweak), which i've done for years - that's what it's not letting me do anymore. it's not showing up in the bios/uefi menu. so what ventoy does, i'm able to do with clonezilla - make the bootable drive. it's just that drive isn't being seen in bios/uefi anymore but all other usb drives are - clonezilla, usb installer. i'll try ventoy as a test is and see if that makes a difference.

1 Like

It is worth a try.

I think it is safe to say that this is not due to the USB stick...
User @quaxth has also noticed a similar bug with Zorin OS Lite.
I am going to go out on a limb and tag @AZorin and @zorink to alert them to this continued observation...
It's really baffling. The Ubiquity installer is the same.

looking at ventoy - i don't make iso clone. i clone the computer to the usb with clonezilla in the middle, so the usb stick is ready to go right after the clone. based on the ventoy documentation, that's what it looks like ventoy does. it's more like balena etcher than clonezilla. i use balena etcher to make the usb installer from the zorin iso. but i take my best computer build and then boot into the live clonezilla usb drive and then clone computer to usb. then on the other side, i clone usb to computer to make the cloned computer. all of this is working. it's just not being recognized

1 Like

does anyone think that automatic sleep of the usb might be the issue?

was reading something about this:

"check if the automatic suspension is causing the problem

cat /sys/module/usbcore/parameters/autosuspend

This should return a value of 2, which means that automatic sleep is enabled. You can fix this by editing the grub:

sudo nano /etc/default/grub

Here, search:


Change this to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

Press Ctrl X to save the file and exit.

Next, they update the grub:

sudo update-grub

When complete, reboot the system."

the computer does report back "2"

Nice bit of research.
Mine returned a 2, as well. And, I did not know about this feature, at all. I learn a new thing. :slight_smile:
It is worth changing it and testing it...

another thing i'm noticing now is in my grub menu. i set the grub to show the menu for 5 seconds to give me a chance to run some recovery tools or jump into the uefi menu instead of having to do the tapping a key thing. now that i'm paying attention, i notice that if i have a clean insteall it just gives me 3 choices - zorin, recovery, and uefi (all written more extensive, but that's what they are). so when i have a clean install it just has the 3 because that's my grub for the computer. but once i plug in a cloned os, the grub menu changes and there are many more choices, like it's reading the grub menu of the os drive before the grub menu of the computer itself. and maybe were i ran into some problems is when i took a z15 computer and without wiping it, just cloned a z16 build on it. because even though i was using a z15 computer, some times the grub menu would tell me that z16 was a choice to boot into and there would be like 9 choices of things to do vs the usual 3. my plan is for some tests is to do some installs, but then update-grub and boot repairs from the z usb installer to try to get the cleanest grub i can get. then make sure to wipe anything that will be cloned to, so there is no confusion of which grub i'm using.