Zorin 16 Lite good for Asus H97m-e?

Mods, please move my post if I’m in the wrong thread.

Other than Thunar (that steaming pile), is Z16 lite generally running ok? Sorry if this has already been answered. I’m considering replacing my wife’s OS from Z15 gnome to xfce. Her h97m-e (shame to the Asus brand) is quirky and I intend to try either z15 xfce or z16 xfce on it.

As you already know, I use Nemo on Zorin Lite. Thunar's... ok... I like some of it.

I would go for it. Even if there are a couple bugs on a known quirky computer, nothing a couple of updates cannot fix.
In my own opinion, Zorin OS 16 Lite is running like a champ.

1 Like

Thanks.
Yeah, I recall nemo. I never found a solution to Nemo as default replacing Thunar but that’s a minor issue I learned to live with.

@carmar , can you help me understand that issue?
Step by step, help me to replicate it.

The following steps are what I follow to replace Thunar with Nemo (they're all from what you posted on that thread):
a. install nemo from synaptic or terminal.
b. settings -> preferred applications -> utilities -> change file manager to "other" and input /usr/bin/nemo
c. settings -> session and startup -> application autostart -> add -> for command input nemo.desktop
d. edit ./config/mimeapps.list to have the line inode/directory=nemo.desktop

Then, the only time I get an error from copying is from a folder -> desktop (desktop -> folder is ok). error

Ok, so copying from a folder (any folder in any location) TO the desktop?
Drag and Drop? Terminal?
Rifght click plus copy paste? Into Desktop folder or onto desktop (That has a wallpaper and a conky on it)?

I cannot replicate this, at all. Not on Z16 Lite, I couldn't on 15.3 Lite and not on Zorin 16 Core with XFCE installed. I do not have Cinnamon installed.

I do this differently:
utilities > file manager > I type in nemo

EDIT: Bap... got it.
Right clicking a file on the desktop (copy) and then right clicking in a folder (paste) I replicated the issue.

Ok...
@carmar , I fixed it.

First, open dconf-editor and navigate to /org/nemo/desktop > ignored-desktop-handlers
Choose Custom value.
In mine, I already have conky added. You need to add 'xfdesktop' to this. If you have no conky and no other ignored handlers, it would like like ['xfdesktop']
On mine, because I have conky (This is for others that have other ignored handlers), it looks like ['xfdesktop', 'conky']

Apply and exit.
Now, open xfce4-settings-manager (Settings in Zorinmenu-lite app menu) and > Desktop Settings and then Icons. For icon type select none.
Back out to the Main Settings. Go down to System > Session and Startup > Application autostart and click the add button. Enter just nemo-desktop in all fields to make it easy. Or you can make your own name and comment...
But command is nemo-desktop

Once done, Log out and in and enjoy the problem being gone.

1 Like

I try to make things difficult for you, not because I'm dense but because I'm trying to improve your mind-reading skills.

But yes, your most recent post fixed it. Thank you very much.
Alas, giving up my mod perks also means I can't edit my OP in Nemo as default replacing Thunar . Could you do me a favor and add "Solution: Zorin 16 Lite good for Asus H97m-e? - #7 by Aravisian" (without quotes) to the beginning of the OP on that thread (or something similar) linking it to your solution? Thanks again.

I know another solution to this...

O.P. edited in other thread.

1 Like

Thanks. One last thing, I noticed that using xfdesktop made the trash can desktop shortcut disappear. I websearched “xfdesktop trash can” but the results I get don’t seem to relate to my issue. Any thoughts?

This is a very minor issue - I really like the new look - so please disregard if it’s not something off the top of your head.

Ummm... I'm not sure. But I will look into it. I have some ideas as to why this might be...

1 Like