Zorin 16 not shutting down in ASUS vivobook

I have ASUS vivobook 15 X510QA with AMD 9720p processor. Zorin 15 was shutting down properly but I have installed Zorin 16 and it is not shutting down properly. The cpu fan always remains on and white led also remains on on power button. So have to manually keep power button pressed for 4-5 seconds even after click on shutdown button in Start menu.

1 Like

Many users have been commenting on this lately. I wonder if reverting to an earlier kernel may do the trick...

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Reboot - tap esc or tab if needed to bring up Advanced options for Zorin and choose to boot from the 5.8 kernel and test...

4 Likes

Are we sure I can install older kernel in Zorin 16? I mean is it advisable? I daily update zorin os so this kernel will be wiped out anyhow when I will use sudo apt autoremove --purge command. I just do not want to break os just because of this kernel. Or should I proceed with your suggestion?

1 Like

Hi bro

hi @100WCharge

1 Like

Can you try writing shutdown in the terminal to see if it gets fixed

If it still does not get fixed, then there are 3 ways out.

First, you need to downgrade to an older kernel.

Second, you need to reinstall Zorin OS.

Third, you need to install any other Linux Distribution and check if the problem exists.

If all three does not work, then it's a hardware issue. We would help you further on it.

Regards,
100WCharge
Tech Support

@100WCharge just tried shutdown command. no luck! :slightly_frowning_face:

1 Like

Then you can try any of the above three ways.

@100WCharge it was working perfectly fine in zorin 15. So I do not expect any hardware issue. moreover windows 10 is running absolutely fine along with zorin.

1 Like

Then we can strike this out.

You try some other ways mentioned above.

@Aravisian you are spot on man! :slightly_smiling_face:downgrading kernel to 5.8.0-63 solved the problem. can we aware Artyom Zorin of this bugfix for this particular laptop model? big thanks! :+1:

2 Likes

Yes, you can use the 5.8 kernel. Really, the later kernels apply far more to the Newest Hardware.
You can also see here to prevent updating the kernel from changing which you boot into:

2 Likes

Congratulations to you and @Aravisian

1 Like

There's a reason behind why did downgrading the kernel work.

The kernel 5.8.0-63 is in Zorin OS 15, in which your computer was able to shut down. As the the newer kernel does not support your laptop's shut down capability, that is the reason why when you downgraded your kernel, you just went back to Zorin OS 15, without fully installing it, and it worked for you :grinning:

My recently updated ZorinOS 15.3 Core is currently on kernel 5.4.0-92 not 5.8.0-63.

1 Like

Then how is kernel 5.8.0-63 working for Zorin OS 16? And how did @Aravisian know which kernel it might work with?

There is no reason to think it wouldn't. It is common drivers package for Ubuntu 20.04.

I've been doing this for a while... And what I know, vs what I am guessing on, might be a topic for debate...

1 Like

I have this same issue on my new desktop...

CPU: Quad Core AMD A8-9600 RADEON R7 10 COMPUTE CORES 4C+6G (-MCP-) 
speed/min/max: 1399/1400/3100 MHz Kernel: 5.13.0-27-generic x86_64 Up: 13m 
Mem: 2030.5/3791.0 MiB (53.6%) Storage: 476.94 GiB (2.3% used) Procs: 215 
Shell: bash 5.0.17

this did not happen when the shop installed windows10 ...
looked in ubuntu forums, where addinf apm=power_off acpi=force didnt work too.. any other way to solve this issue