Zorin 16 Pro - Audio device selection not surviving reboot

Hey there guys!

As the title of this thread suggests, the standard audio device is not persistent after a reboot, i.e. I have to re-select my audio device after every reboot.

Is there anything I can do to make the audio device selection survive a reboot?

Best wishes and I'm so happy with Zorin OS (very new :slightly_smiling_face: )

sudo nano /etc/pulse/default.pa

Look through and comment out the line:

load-module module-switch-on-port-available

making it look like:

#load-module module-switch-on-port-available

Hit ctrl+x to exit, the y key to say yes to save, then the enter key to save as current configuration.

Hey there, thank you again for your efforts. But unfortunately that didn't do the trick. I made the line a comment and rebooted and it still selected the other audio device.

To be more precise: The only audio device I use is called "Starship/Matisse HD audio controller", but it keeps selecting "Digital output - Logitech Pro X Wireless headset". Any further ideas?

Appreciate your help! :slight_smile:

hmmm... perhaps it no longer works on 20.04? According to this thing I just looked up, anyway:
https://itectec.com/ubuntu/ubuntu-how-do-you-set-a-default-audio-output-device-in-ubuntu-18-04/

Maybe the chosen solution will work for you.

Thank you so much, worked perfectly! Just for my interest: Will there be something implemented in future Zorin OS? Something like "Select standard audio device"? I'm missing a few features from windows (like the above) or the ability to configure the mouse wheel speed (Found a working solution for that already though).

Don't get me wrong: Zorin or Linux with Zorin has quickly become my #1 choice of OS, but there're a thing or 2 that might come handy with Zorin as well :slight_smile: Just my 2cents :slight_smile:

Thank you anyways for your awesome work across this forum :rocket:

2 Likes

I can only suggest using the Feedback forum to present these improvements.

1 Like

Fair point! Will do at times :slight_smile: Thank you very much :heart:

1 Like

Hey again, I think I was too quick. While the command works when I'm entering it in a terminal (pactl set-default-sink alsa_output.pci-0000_0f_00.4.analog-stereo), it doesn't automatically work if I reboot my computer :confused:

I added this command in start programs but it seems it is not executed? I have no idea, any help is still appreciated.

Ah and: Somehow I need to enter my password in something called "bla bla keychain". I forgot the exact wording, but could it have something to do with that? That it maybe prevents the execution as it is not authorized? Or something? :smiley:

....that... actually that totally should survive reboot.

Can we test something... Ensure that is set, then go to your home directory and rename ~/.config to ~/.config-bkp

That creates a back up of your config files while also making your config files inaccessible to the system - causing it to use all default configurations.
Reboot
Ensure the above again and set sound device and reboot one mroe time to test...

If that makes a difference, then there may be a config file in your home directory overriding your settings.
We can then see about sussing it out.
If it doesn't, punch me in the head no more than five times.

Hey there! I'm rebooting for the 2nd time now. Just FYI at the first reboot the audio device was still wrong :see_no_evil: btw where can I find the config file now again sir? It's not in /home anymore and I'm already sweating because it was such a marathon to get to this point. Now everything is set back to default. Also: I don't have super user privileges anyomore...if I enter my password it says that it's wrong :thinking:

Okay I got su privileges again, but I cannot find the .config file anymore. Also, the device is still the wrong one after the second boot :confused:

~/.config and ~/.config-bkp
If you are not seeing either in your File Manager, hit ctrl+h to reveal.

Audio device not staying selected... I am at a loss.

In your travels... Have you ever talked to someone who is a linux-user that complains about Systemd?
Lennart Poettering?
If so, have you ever wondered why there was so much venom?

This is why.
Pulseaudio combined with Systemd modules.

-sigh-
I am not a systemd hater... not really. Not a lover, either. But I do know that while it has some Good Points, it has some flaws that are Pretty Killer.

1 Like

Hey there man! Thank you a ton again for all your efforts! Control+h did the trick and I'm so delighted! :smiley: It really seems that this is a bit of a pain in the b_u_m, however, not a thing I couldn't live with :slight_smile: After the initial finetuning is done now I won't reboot too much anyways (Running a Plex server here which is basically online 24/7 ^^). But you tried your very best and I'm veeery thankful for all your help! Too bad nothing worked out, but all good :slight_smile: Would there be any thread or something to report this? Again feedback section?

1 Like

I think the ZorinGroup currently has a "kill on sight" bounty out on me so if you could just claim you never saw me...
That might help.

2 Likes

Hahaha dude btw you're funny af! I laughed harder than I should 2 comments of yours ago :laughing:

HOWEVER! Guess what... After restoring my previous config file it's working now!!!! The correct audio device IS selected after every boot like... What? :joy:

2 Likes

I knew I could do it.
I only needed to believe in myself.

1 Like

Lmao! 5/5 stars, would get support again! Believe in the heart of the cards!

For the first time I could hear Zorin boot up sound :slight_smile: if that's not worth the support award of the year idk what is

2 Likes

One thing I have learned on the forum is that however confident I am that the fix I post right away is going to fix things up, most common likely response is:

"It didn't work."
More often, the trying different things leads to finding clues- many times it helps the O.P. figure it out in one way or another on their own. But the most important thing is- the person gets a reply- even if it does not fix things right up- that they were cared about.
Failure counts for much more than silence.

1 Like

Wise words Aravisian. As a full time gaming support agent I can only agree! The most important thing is that the one searching for help feels cared about, not much to add :slight_smile:

Are you btw a staff member of Zorin? Or just some sort of Zorin forum super hero? :slight_smile:

1 Like