Zorin 16 Pro - Audio device selection not surviving reboot

No, not a member of ZorinGroup or a developer.

I am a mechanic.
Classic Car restoration - though since Covid-19 have been having to degrade myself to working on modern junk.

1 Like

Modern junk you say, what's that? :smiley: Covid-19 is a pain indeed. I've been lucky as I was working from home long before it all started, so I don't notice too much of a difference luckily :smiley:

Appreciate that you're taking so much of your free time to help noobs like me :relaxed:

1 Like

I am a Linux noob as well, so gotta help eachother out.

And who said anything about my time being free?
I took the liberty of adding a small gratuity to your bill. Just my way of saying thanks. :slight_smile:

Lmao xD Wow! What a great way...to say...thank you :laughing: :man_facepalming: If you're a noob Idk what I am in terms of Linux hehe

1 Like

If you think that I am not a noob... then remember this moment when you think of where you will be in your Linux Journey a few months from now. With Linux, you never stop learning. But being a "noob" in Linux is merely a mindset - perhaps a choice.

I was not entirely kidding about my time not being free... Ok you are not getting a bill - but I am working.
Which gets... hectic... at times. The shop joke used to be: "Shut the garage, someone is wrong on the internet."
Now, the screen is up and if someone sees the blue highlight (new post) on the top of the forum they yell, "Ding order up!" And I'm hauling it across the garage to "Shut the garage, someone is Stuck on the internet."
We're a crazy crowd.

1 Like

What the actual f did I just read :laughing: I'm not sure if I understood this correctly with my limited English skills, but what are you actually working as then? :smiley:

Ahhh! I see :smiley: Now it all comes together :smiley:

2 Likes

I have no idea why, but it's stopped working again....Out of nowhere. It survived 4-6 Reboots and now I rebooted and again the wrong audio device is selected at boot. I'm desperate but I only wanted you to know I WILL LIVE WITH THAT NOW :smiley:

1 Like

This suggests that something is creating a configuration in your ~/.config directory that is redirecting your output.
If you get to the point of not being able to live with it, maybe you can explore that folder a bit and poke around for anything affecting Sound.

I will do so right now! Thank you for the suggestion. Also I noticed other weird sound behavior again, which I thought was solved already. The sound gets all metallic and distorted and it sounds like you'd speak into a metal can. When it happened, I noticed that there're new sound outputs within the Zorin OS settings. Something along the lines like "Voice output distortion controller" and "Voice control distortion dummy", right below the field of "system sound" :thinking: Anything coming to your mind in that regard?

Edit: The names of the devices are recovered from memory, not original

And it gets even weirder. It starts right in the second when I open this tab (https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-21-10) in Mozilla :thinking: Just by opening the tab. Dafuq?

Bildschirmfoto vom 2021-08-24 22-18-07

Edit: I checked the settings now and nothing too obvious (for me at least) in there. But I renamed 2 files to filename.backup, which are .config/pulse/cookie and nvidia-settings-autostart.desktop. I'm just guessing blind, but both could solve the issue to my understanding. Mainly, because I don't have any Nvidia device in my computer anymore. Would be great to hear if you think that's utter b.s. or not. Will reboot and let you know :heart:

EDIT 2: Where do these weird devices come from anyway?

EDIT 3: Oh and what's weird as well is that the correct audiodevice is and probably was always selected in /puse/c6ac1db53d634e299ab53f97a946ae27-default-sink, which is my speakers, so I think you're very right with the thought that something's overwriting it, but what? :weary:

Last EDIT (4), promised: What's that SSH agent autostart program and do I need it?

LOL What's wrong? Were you starting to drive yourself crazy?
SSH agent is used for authenticating remove connections. If you are not using any (Remote printer, share, samba, etc) then you would not need it to Autostart.

Removing or renaming .config/pulse is standard procedure to see if a pulse configuration file is causing troubles, so you are correct.

Somehow, yeah :joy: I still have no idea how to properly fix it. The fumbling with the files in /pulse didn't resolve it, unfortunately. However, I will continue to live with it :joy: I'm running out of options to resolve this issue and selecting an audio device at boot is high-level complaining :joy: So all good! Thank you again for your outstanding support! :slightly_smiling_face:

1 Like

But replacing the entire ~/.config directory earlier did... This implies that there is something within that directory, if not in the Pulse folder.

Yes, definitely. Something is accessing the sink(s) or overwriting something :thinking:

audio

"Connection refused"

Can you please test again whether replacing the entire ~/.config directory does resolve (For a Limited Time)? Perhaps the first time was coincidence.
If it does, then we can restore the original (Delete the new ~/.config that forms and rename the ~/.config-bkp to ~/.config) and start examining the items within to suss it the culprit.

Hey again!

Well basically that is what I did the first time after your advise (I changed /.config to /.config.backup (then it worked) and then I deleted /.config and renamed /.config.backup back to /.config. And somehow it worked then for a while, now not anymore. Or was that not the point?

Yes, I was suggesting repeating that procedure to ensure that it did cause the proper behavior, even if temporary, and was not coincidental that doing so before appeared to cause the proper behavior.

Oh okay! At it kind sir!

If you don't mind Aravisian, you could/might check a new issue of mine which is impacting me on a much higher level here Can't mount network share as read/write

But I will follow your advise now once again :heart: