Zorin Forum

Zorin 16 Wifi hook-up

Limited ??? did you turn of secure boot ?

He means limited to number of posts here on the forum I think.

I think this will solve the headache for everyone for 13 Pound.

https://www.amazon.co.uk/EmNarsissus-Compatible-Wireless-Frequency-Reception/dp/B08MT4DR26/

Ok well another day, another try. Starting up again has left me with a new Terminal page, and so not sure what ramifications leaving the old one unfinished has.
With the 2 suggestions of an alternate dongle maybe under the circumstances that is the way forward for the present. Although in preference I would have preferred to resolve issue through the terminal if for experience if nothing else. Having just tried again it would appear I am still restricted.

Hi, I have tried to continue with the thread of this topic but the site seems unwilling for me to display results from the terminal. So it would seem if I am to progress I will need to use an effective dongle. Therefore for the moment I will purchase your suggestion, and as I am not sure about the integrity of the CD on the Toshiba I am praying it will work OOB. I take this opportunity to thank you all again. Hopefully it won’t be too long before my restrictions are lifted as I am sure to need help again shortly

What do you mean by this?
Are you using the "Upload" tool to add a screenshot and the forum is not allowing it?

3 Likes

I am really confused as well. @PeterC are you facing problems while posting stuffs in the forum?

3 Likes

As I have already explained that to you - in my over 15 years of Linux use, I've never seen Linux drivers are supplied on a CD. It almost always contains Windows drivers and occasionally Mac drivers.

For Linux, it is either works OOB, or requires a third party driver downloaded from the net or compileing it from the source, or does not work at all.

I saw again and again, people made a mistake trying to purchase Linux compatible hardware by the product name. The manufacturers could change any component without advanced notices. The only way to know for sure is to look for the model number of chipsets it contains.

It is also advisable to go for a online shop which offers you an easy return. Sometimes people who are selling the item has no idea what they are selling. For this reason I seldom use evileBay. That is my last resort when I cannot find what I want at Amazon with a reasonable price tag.

Ok all, I must thank you for your perseverance. What I am trying to say is that when I paste the result of your terminal instruction into the thread for you to examine, it comes up with “Sorry, new users can only put 5 links in a post” then does not allow me to upload the reply.
I have tried again with this reply and the restriction is still in place, although obviously the procedure in the terminal is no longer there, it does give you an idea where I got to.
All that said I do wonder why it then allows me to upload none-technical responses??? And I too would love to know what the term ‘links’ refer to?

Sorry- 'this reply' should read 'the reply'

This is very strange; I have not seen you post a single link, yet.

Are you able to use the upload tools supplied by the forum?
Look to the toolbar above where you type your reply and you can find a parsing tool, image uploader (Screenshots), etc.

Ok well I’m obviously getting something wrong. And yes, I now see what you mean at the toolbar in the reply box there are options. However, I did initially add the text from the terminal which did upload and assumed after that it was ok to directly add. But I will now try adding the ‘Terminal’ text which I still have in word into the reply window, but which one of the options is best for such text?

The parse icon. It looks like </>

eter@peter-Satellite-C660:~$ sudo apt install git
[sudo] password for peter:          
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  git-man liberror-perl
Suggested packages:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk
  gitweb git-cvs git-mediawiki git-svn
The following NEW packages will be installed
  git git-man liberror-perl
0 to upgrade, 3 to newly install, 0 to remove and 18 not to upgrade.
Need to get 5,465 kB of archives.
After this operation, 38.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Ign:1 http://gb.archive.ubuntu.com/ubuntu focal/main amd64 liberror-perl all 0.17029-1
Ign:2 http://gb.archive.ubuntu.com/ubuntu focal-updates/main amd64 git-man all 1:2.25.1-1ubuntu3.2
Ign:3 http://gb.archive.ubuntu.com/ubuntu focal-updates/main amd64 git amd64 1:2.25.1-1ubuntu3.2
Err:1 http://gb.archive.ubuntu.com/ubuntu focal/main amd64 liberror-perl all 0.17029-1
  Temporary failure resolving ‘gb.archive.ubuntu.com’
Ign:2 http://gb.archive.ubuntu.com/ubuntu focal-updates/main amd64 git-man all 1:2.25.1-1ubuntu3.2
Err:3 http://security.ubuntu.com/ubuntu focal-updates/main amd64 git amd64 1:2.25.1-1ubuntu3.2
  Temporary failure resolving ‘gb.archive.ubuntu.com’
Ign:2 http://security.ubuntu.com/ubuntu focal-updates/main amd64 git-man all 1:2.25.1-1ubuntu3.2
Err:2 http://security.ubuntu.com/ubuntu focal-updates/main amd64 git-man all 1:2.25.1-1ubuntu3.2
  Temporary failure resolving ‘gb.archive.ubuntu.com’
E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/libe/liberror-perl/liberror-perl_0.17029-1_all.deb  Temporary failure resolving ‘gb.archive.ubuntu.com’
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/git/git-man_2.25.1-1ubuntu3.2_all.deb  Temporary failure resolving ‘gb.archive.ubuntu.com’
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/git/git_2.25.1-1ubuntu3.2_amd64.deb  Temporary failure resolving ‘gb.archive.ubuntu.com’
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
peter@peter-Satellite-C660:~$


Problem solved, thanks you. I just need to try again with Zorin now.

Please open Software & Updates from the app menu and change Download from to "Main Server."
The regional servers do not hold water.

Ok done that, do I now follow the procedure given previously which is -
First write in terminal sudo apt install git and hit enter
Then write in terminal git clone GitHub - FreedomBen/rtl8188ce-linux-driver: This modified version of the RealTek WiFi driver fixes some issues with RealTek cards on Linux. && cd rtl8188ce-linux-driver && ./install.sh and hit enter

Are you connected to the net on the computer that is afflicted by other means?
If so, then yes run

sudo apt update && sudo apt full-upgrade

Then once done, run the commands.

No unfortunately the pc in question does not connect, there is a dongle on its way so when that arrives I will hope that connects and have a go, again. So basically the procedure is.
update with 'sudo apt update && sudo apt full-upgrade'
then follow the previous procedure. and it will hopefully be able to connect to the net under its own steam-so to speak.

1 Like

Yes, but you can only do this when it is able to connect.
Otherwise, you may need to download drivers on another computer, then transfer them with a USB.

1 Like