Zorin 17.1 / Nvidia support

Hi, I've been trying to track down some issues with Firefox and Youtube. I eventually started to use Chromium to view videos without interruptions. However, I wanted to use Firefox and so I tried to set my video driver to the proprietary Nvidia 390 driver. Big mistake. The system came back with an error, so I tried to reboot. However, the display manager wouldn't load and then I tried the previous version with the 6.5.0-35 kernel and that worked normally, but I tried loading some drivers and that failed like before and now I am at kernel 6.5.0-25. How to I get back to the 6.5.0-41 kernel with the nouveau driver?

Have you tried booting older kernel from grub, "Additional Options for Zorin" menu item?

Also this may help you: [HOW TO] set an older kernel to default boot

Yes, that is what I am running now. The first and second choices are now messed up.

I got into this mess in the first place by going into the "system & updates" app, select the tab "Additional Drivers", and finally selecting the "Using Nvidia driver".
An error was produced and when I rebooted no gui would load. Ugh I did this twice with the first and second selections in the grub menu.

I am now running an older version of the system selected through the grub menu (6.5.0-25-generic).

I have been reading through many forums and it seems I am running the nouveau driver:

~$ lspci -k | grep -EA3 'VGA|3D|Display'
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 420] (rev a1)
Subsystem: Bitland(ShenZhen) Information Technology Co., Ltd. GF108 [GeForce GT 420]
Kernel driver in use: nouveau
Kernel modules: nvidiafb, nouveau
~$

If I stay with this version, will the next system update work properly?

Well I seem to be going deeper into the abyss. I tried to use the recovery mechanism for 6.5.0-41-generic on the grub menu. I used the "dpkg repair broken packages" along with networking and I get error messages to the affect of "No candidate ver: linux-objects-nvida-390"

I booted from the recovery screen and the display resolution is 1600x1200 not 1920x1080. The highest setting in the software settings screen is 1600x1200. At this point I do not know what to try.

Sorry, I don't have Nvidia graphics, so cannot suggest driver for your NVIDIA Corporation GF108.
I don't know if that card has become unsupported or not. This, although not exactly your case, may be worth a read. Unable to use proprietary NVIDIA graphics driver after upgrading from Lubuntu 20.10 to 21.04 (20.04 LTS to 22.04 LTS) - Ask Ubuntu

Thank you for responding. I tried

sudo add-apt-repository ppa:kelebek333/nvidia-legacy

in the recovery command line and this returns with connection timed out:

Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 364, in
sys.exit(0 if addaptrepo.main() else 1)
File "/usr/bin/add-apt-repository", line 347, in main
shortcut = handler(source, **shortcut_params)
File "/usr/lib/python3/dist-packages/softwareproperties/shortcuts.py", line 40, in shortcut_handler
return handler(shortcut, **kwargs)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 82, in init
if self.lpppa.publish_debug_symbols:
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 120, in lpppa
self._lpppa = self.lpteam.getPPAByName(name=self.ppaname)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 107, in lpteam
self._lpteam = self.lp.people(self.teamname)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 98, in lp
self._lp = login_func("%s.%s" % (self.module, self.class.name),
File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 494, in login_anonymously
return cls(
File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 230, in init
super(Launchpad, self).init(
File "/usr/lib/python3/dist-packages/lazr/restfulclient/resource.py", line 472, in init
self._wadl = self._browser.get_wadl_application(self._root_uri)
File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 447, in get_wadl_application
response, content = self._request(url, media_type=wadl_type)
File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 389, in _request
response, content = self._request_and_retry(
File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 359, in _request_and_retry
response, content = self._connection.request(
File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1725, in request
(response, content) = self._request(
File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 144, in _request
response, content = super(LaunchpadOAuthAwareHttp, self)._request(
File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 184, in _request
return super(RestfulHttp, self)._request(
File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1441, in _request
(response, content) = self._conn_request(conn, request_uri, method, body, headers)
File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1363, in _conn_request
conn.connect()
File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1153, in connect
sock.connect((self.host, self.port))
TimeoutError: [Errno 110] Connection timed out

I was hopeful this would work.

My solution was to dig around my son's old computer gear and found a GTX750Ti card that would work in my old computer. I installed the driver via

sudo apt install nvidia-driver-550

reboot and all is in order. The nvidia app shows all of the GPU settings. The only difference is that "Software and Utilities" -> additional drivers, show that I am using a manually installed driver.

3 Likes