Zorin 17 - Nvidia 390 driver install says exit status 10 (313)

I have Zorin up and running with the Nouveau drivers, but trying to switch to Nvidia. Driver 390 comes up in "Additional Drivers" but install fails with:
Screenshot from 2024-03-01 11-41-41

I have a Quadro 1000M video card on the old laptop.
lshw -C video shows:
description: VGA compatible controller
product: GF108GLM [Quadro 1000M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:37 memory:f0000000-f0ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:5000(size=128) memory:f1080000-f10fffff
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
resources: irq:38 memory:f1400000-f17fffff memory:e0000000-efffffff ioport:6000(size=64) memory:c0000-dffff

Anyone have suggestions or is this card simply too old?

(saw another thread recently posted with no details, unsure if it is the same problem)

You can use kelebeks legacy driver support:

sudo add-apt-repository ppa:kelebek333/nvidia-legacy

sudo apt update && sudo apt install nvidia-340-updates nvidia-340-updates-dev xorg-modulepath-fix

This may help buy you some more time with the card preventing e-waste.

1 Like

Tried this....booted to a text only terminal mode afterwards. So I went through the steps listed here:

It threw up a bunch of error messages when I ran the NVIDIA driver .run file (which I grabned from their site), but I was able to reboot back in graphics mode with nouveau. Guessing the 'purge' was really all that had an effect.

Just for fun I tried to switch to 390 again...it never seemed to complete the install through the software updater, so I hit "close". All of the sudden it claims to be running nvidia drivers through the settings and sees the Quadro card. Running the "valley" demo shows an improvement (albeit still terrible, but to be expected).

So it now seems to work. Go figure.

1 Like

Update: I was wrong

After reboot nothing would run. Even firefox would crash after launch. So the failed 390 driver install, or 340 don't seem to work on my system.

This is beginning to sound like a failing card...

I have a similar video controller and the same issue and error while installing package in Zorin 17: [Nvidia 390 driver install says exit status 10 (313)] and found no solution yet.

Beschreibung: VGA compatible controller
Produkt: GF108GLM [NVS 5200M]
Hersteller: NVIDIA Corporation
Physische ID: 0
Bus-Informationen: pci@0000:01:00.0
Logischer Name: /dev/fb0
Version: a1
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: pm msi pciexpress vga_controller bus_master cap_list rom fb
Konfiguration: depth=32 driver=nouveau latency=0 resolution=1920,1080
Ressourcen: irq:29 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(Größe=128) memory:c0000-dffff

In my tests I now have Nvidia driver 340 working fine. One thing to be aware of, in my case at least, is that in the bios I found I had to select Discreet graphics specifically. The default was "Nvidia Optimus", which is supposed to auto switch but I suppose may not be supported.

Might be worth ensuring only Discreet graphics is selected, then installing the driver and seeing if that helps.