"Zorin Appearance" not working (after installing 20.04 Zorin update)

Hi!
I just installed the last Zorin update to 20.04 version in a Ultimate edition, and the section (or app) “Zorin Appearance” doesn’t work (I click on it and it doesn’t do anything).

Could you help me to re-install it or, maybe, re-install all the update?
I’m not a linux expert at all and I don’t know how to solve this.

Thank you so much.

Hi, artesan0.
Can you open your terminal (Ctrl+Alt+t), and type in sudo apt dist-upgrade and press enter (input password when asked)? Let it run and let us know if that helps.

PS - Also, would you mind checking if your Software Updater Settings, Zorin Software tab points to Download from the Main Server?

Hi carmar,
thank you so much for your quick response, I appreciate it.

I ran sudo apt dist-upgrade as you recommended me and it finished okay, but “Zorin Appearance” is not working yet.

I checked the Software Updater Settings, and I don’t have a Zorin Software tab, instead I have a Ubuntu tab? and it points to the main server, yes.

Artesan0, could you check your current installation in terminal with

zorin-appearance --version

See what kind of response it gives you.

Not sure about this, do you mean the update 15.3 including the latest kernel?

You might try removing and reinstalling the following packages in terminal.
If you are using Zorin Core:

sudo apt-get install zorin-appearance

sudo apt-get install zorin-appearance-layouts-shell-core

sudo apt-get install zorin-appearance-layouts-support

sudo apt-get install zorin-auto-theme

If you are using Zorin Lite:

sudo apt-get install zorin-appearance

sudo apt-get install zorin-appearance-layouts-xfce-core

sudo apt-get install zorin-appearance-layouts-support

sudo apt-get install zorin-auto-theme

1 Like

I ran this “zorin-appearance --version” as you told me. This is the result, it seems like something is not good (I have spanish version):
“(zorin-appearance:9987): GLib-GIO-ERROR **: 00:41:37.706: Settings schema ‘org.gnome.nautilus.desktop’ is not installed
«trap» para punto de parada/seguimiento”

About 20.04, I think this is the Ubuntu version based on Zorin is. This was the last automatic Zorin update.

I ran all the commands you said, but it still doesn’t fix it.

Do you have Synaptic Package Manager? (under System Tools?)
If no, then in terminal, type sudo apt install synaptic to install.

If yes, then start it. Do a Search for “zorin-appearance”. In the list, installed packages have a shaded box to their left. Right-click on that entry and select “Mark for Reinstallation”. Then click “Apply”.

Aravisian already walked you through the terminal method, so this may not work but its worth a try.

Are you using Zorin-Lite?

Zorin 15 is built from Ubuntu 18.04.
Zorin 16 will be built from Ubuntu 20.04.

Good morning, carmar.

Not sure if I had Synaptic Package Manager, but just installed it with the order you showed me.

After that, I searched for “zorin-appearance” into it, and it showed me this:

I did right-click and saw the “Mk for Reinstallation” option, but it is grey and I cannot click on it (not available), I don’t know why. The only available options are uninstall.

@Aravisian I’m running Zorin OS 15 Ultimate (that’s the license I bought a while ago).

What happens if you install Nautilus from terminal?

sudo apt-get install nautilus

Also shemas from terminal?

sudo apt-get install gsettings-desktop-schemas

If no luck there, try

glib-compile-schemas /usr/share/glib-2.0/schemas/

I just ran both, 0 installed or updated.

Same message when I run “zorin-appearance” --version:
(zorin-appearance:56667): GLib-GIO-ERROR **: 10:37:28.364: Settings schema ‘org.gnome.nautilus.desktop’ is not installed
«trap» para punto de parada/seguimiento

I just edited in an after-thought that I will repost here: :wink:

glib-compile-schemas /usr/share/glib-2.0/schemas/

1 Like

OK, @Aravisian.

I just ran the last one you edited. Result:

hector@DREAMS-PC:~$ glib-compile-schemas /usr/share/glib-2.0/schemas/
No such key “notify-with-tray” in schema “org.gnome.evolution.calendar” as specified in override file “/usr/share/glib-2.0/schemas/25_zorin-os-default-settings.gschema.override”; ignoring override for this key.
No such key “enable-hot-corners” in schema “org.gnome.shell:zorin” as specified in override file “/usr/share/glib-2.0/schemas/50_zorin-desktop-session.gschema.override”; ignoring override for this key.
Falló al crear el archivo «/usr/share/glib-2.0/schemas/gschemas.compiled.2CL2R0»: Permiso denegado

You may have something in your ~/.local/share/ directory that is overriding your /usr/share/glib-2.0/ directory.
You can test this by renaming the directory to ~/.local-bkp and rebooting. Test if Zorin Appearance is working.
If it is, then it may be necessary to sort through your .local-bkp directory to transfer over any user data you wish to keep that was not affecting this issue.
If it does not work, then remove the replacment ~/.local directory that was formed after your reboot and rename the ~/.local-bkp back to ~/.local - at which point: This may be a schema syntax error. If so, I am uncertain how to proceed. The Zorin Team may know the proper fix on that. As you chose Zorin Ultimate, you also have the ability to us ethe Contact form that comes with it.
And we can shoot them a message from this forum - keep in mind, it may take some time for them to see and record the response.

I tried that @Aravisian, but Zorin Appearance is still not working.
I ran “zorin-appearance --version” and same error.

How I contact the Zorin team then?

@ [artesan0]

or try PM to AZorin on here. :wink:

Thank you so much, I just sent them a message.
Let’s see the solution, I’ll try to remember to share it here with you.

Thank you all!!!