Zorin can't read CTR - Zorin will not boot

I'm new to Linux and Zorin. I have installed Zorin as a dual boot with Win. When I choose Zorin I keep getting the message - Can't read CTR while initializing i8042. I am sure that I did something wrong I just don't know what to do. Any help?

Are you able to log in on Zorin OS? If so, log in and then open a terminal.

sudo nano /etc/default/grub

Arrow key down to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Add the nomodeset grub parameter so that it looks like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Tap ctrl+o to overwrite, then tap enter key to save current configuration, tap ctrl+x to exit the editor.
Now, you must run

sudo update-grub

for the changes to take effect.
If you cannot log in on Zorin OS, you must access the terminal through the Grub Menu. Select the Advanced Options for Zorin then select Zorin on the kernel listed (Recovery)
This will take to you the Recovery Menu. Arrow key down to the option to root - Drop to Prompt.

This will open a terminal in which you can run the same commands and run the editor above.
Still, be sure to remember to run sudo update-grub once saving and closing the editor in terminal before proceeding out of the recovery menu and to normal boot.

Nope. Sometimes some hardware just needs a little extra configuration.

I did exactly as you told me and checked the editor twice to make sure I didn't screw it up. Still getting the same error. Any other ideas that might help?

You could also try the grub parameters noapic acpi=off

That said... That is a harmless error - it is complaining that it cannot recognize the PS/2 keyboard and mouse, which does not adversely affect you at all.

You can just ignore the error on sight.

You can remove it from sight so that you do not have to make an effort of will to ignore it (I have that trouble).
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"
The loglevel=3 parameter will set it so that only serious errors are displayed.

It's just very frustrating because it you think its going to boot but the error comes up first thing and it all stops there.

Ok, so it is also still not booting? The displayed error should not cause a no Boot Issue- And that you were able to enter in the commands shows that the keyboard does work.

Have you tried the noapic acpi=off parameters, then tried to boot to the desktop?

not yet,,but I am going to in just a minute

1 Like

So before I do this where do I need to do the noapic acpi=off parameters?

The same procedure as before - and this is standard in adding a Grub parameter.

First - access and edit the Grub File.

Thank you - I tried that. It took the error away but now it just goes to a blank screen with a cursor blinking. I waited for more than twenty minutes and nothing happened.

According to your profile, you are using Zorin OS Pro (Gnome D.E.).
In that same recovery menu Prompt, can you arrow key to networking and enable networking. With that done, back out to the recovery menu and now arrow key down to drop to root prompt.

sudo apt update && sudo apt dist-upgrade

sudo dpkg --configure -a

sudo dpkg-reconfigure gdm3

Back up from the recovery menu and test booting to the desktop.

I did as you suggested. It seemed to have updated. w
However, when I typed in the last line I got an error message saying
gdm.service is not active, cannot reload
Invoke - rc.d: initscript gdm3, action "reload" failed.

Ok, this gives us some idea of what is causing the failure to boot to the desktop.
I realize we have gone into the Recovery Menu > Root Prompt several times, now. Good practice...
Can you go into the Recovery Menu, enable networking, again and then return to the Root Prompt. run:

sudo apt install --reinstall zorin-os-desktop

Once that has been completed- try booting to the desktop.
Since you have Zorin OS Pro, you may need to run a further command later to regain Pro Features. But I want to ensure you can boot to the desktop, first.

Not a problem - I need to learn as much as I can.
I did the last suggestion - still only a blinking cursor
Did I do a bad install or something?

That is possible. I doubt that you performed it badly - rather, a download that had packet loss or a corruption in the burning of the .iso to the USB stick are far more likely.

Usually, a blank screen with the blinking cursor indicates a problem with the Display Manager.
In Zorin OS Core and Pro, which use Gnome Desktop, GDM (Gnome Display Manager) is the display manager and reinstalling the zorin-os-desktop will reinstall the GDM, as well.
The other commands you ran were for dpkg to reconfigure all installed packages (--configure -a) and the reconfigure GDM (dpkg-reconfigure gdm3).

Since all of these have failed, and I presume the USB "Try Zorin" worked on your hardware, I would recommend a fresh download, burn and USB stick just to eliminate all possible points of failure. Trying the other things first hopefully helps prevent Data Loss from having to reinstall without recovery.

Suggest you have a look at this advice: Before you install
To avoid dissapointment, make sure you take time to verify the SHA256 checksum of the downloaded .iso against the published checksum published by Zorin, before creating boot USB with it.

1 Like

Wait... @Aravisian @zabadabadoo shouldn't he try

systemctl enable --now gdm.service

before reinstalling?

The member could... But the process of proceeding to boot the OS would have started all services.
If he had run the commands in a booted up OS, without a reboot - then yes, using that command would have been part of the process.

1 Like

I appreciate everyone's help and sorry I haven't been able to reply lately (I work nights and its not easy). I just did a reinstall and it works perfectly! So again, Thank you


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.