Zorin Connect & KDE Connect Not Working

At one time, it worked. When I first installed Zorin. I came back today because I wanted to transfer some files and can't do so via USB. (Long story.) But when I turn on Zorin Connect, and also KDE, my android doesn't show. When I look on both KDE and Zorin on my laptop, my laptop doesn't show. Literally nothing anywhere.

And here's the newb part: I have zero idea how to connect one to the other via IP -- but I kind of suspect it wouldn't even let me if I did. HELP!

You cannot have KDE Connect and Zorin Connect installed on the same build at the same time. They will conflict with each other.

In the Android App, you can tap the hamburger icon, then Pair New device.
Now tap the Three Vertical Dots icon, and select add devices by IP.

I installed KDE after Zorin wasn't working. I tried uninstalling via the store but it still remains. #newb

I literally don't know how to add a device by IP. I don't know my computer's IP or how to find it. :sweat_smile: I've tried Googling, but seems like everyone says something slightly different.

Does my phone have an IP address? What's w/ with 1716 -/+ on the laptop client? No clue wtf I'm doing.

image

In terminal, run

ip r

Hints on which one?
image

Tried to most common. Wound up with it being "added" in my app, but then it doesn't do anything. If I tap on it it, it just let's me edit the IP address. Still nothing in devices anywhere.

image

192.168.1.1 is your router. Your network DHCP allocated IP is the last one, 192.168.1.21.

If you have activated the firewall, you need to add the predefined rule to allow Zorin connect through the firewall. I will come back with the Tutorial I posted shortly.

To find the IP address of your phone, open up Settings and then select "About phone", scroll down until you find IP address.

Tutorial here:

1 Like

Danny, which edition of ZorinOS do you run. e.g. Pro, Core, Lite etc. Can you please edit your forum profile to show that info.

Zorin Connect should work on Core (gnome), KDE Connect on Lite (xfce).

Currently running 15.3 Pro - profile edited. :saluting_face:

You may need to install drivers for your phone.

Whenever I connect my phone by USB, i get:

On my phone. Once I hit allow, it shows in the file browser, under other locations.

All without KDE/Zorin Connect.

1 Like

The O.P. mentioned an inability to use USB.
But you do remind me... We have not asked what Android Version is installed on the phone (@dannyjz).

1 Like

If nothing else, may need the ubuntu-extended drivers