Zorin icon in menu bar is looking stretched

I have a Samsung 49 inch CRG9 monitor, with resolution of 5120 x 1440 and the Zorin icon looks a bit stretched on this monitor (scaling is at 125% but it has no effect on it). Is there a way to fix this?

Thanks

Try set scaling to 100%, does it fix it?

No, scaling has no effect on it, even if I disable it completely. I think its just because my monitor is super ultra wide.

UPDATE: I was actually wrong ! After I disabled scaling and did a restart, it did fixed the problem ! However , would be nice if I could fix this issue when scaling is ON

Thanks @Storm

Possible. As there some area of Linux goes poorly with ultra wide. I'll see if I can search for/if any solution.

Thanks,

I've updated my first comment as I was wrong. Disabling scaling has fixed the issue, however its still not ideal as now everything is a bit too small. Would be good to know if there's a fix for it when scaling is applied .

image

Do you have a nvidia card in your computer?

Yes, I do

Okay try this:

prime-select on-demand

if it doesn't work you can switch back by:

prime-select nvidia

Thanks, Unfortunately it didn't work. I don't have another GPU, or CPU with iGPU installed on this machine. So the nVidia card is my main card. I assume the 'on-demand' option is to use the iGPU as main (for laptops etc)

Okay so we need to find another solution...

Just wondering, wouldn't such fix be done in the Zorin theme itself? I guess that's where the styling is for the start menu button ( if there would be a way to know when scaling is applied etc).

the icon itself is a .svg file but what's trigger the stretch I dunno. I'm just a humble user :slight_smile:
You could try making a different .svg file and experimenting with it (require inkscape to manipulate/making .svg file).
Alternative would set the resolution lower and the scaling to 100%

Another alternative is try Wayland instead of Xorg.

Thanks @Storm . That looks like the problem I have and seems like a good fix for it, if not I will give it a try to use a different svg/png file. Its not a major problem anyways, as its just a UI style glitch. This was the only problem I had for years with Zorin and I'm running it on few machines with different hardware and displays.

Thanks again for your help and support !
Stefan

1 Like