Zorin light desktop does not login in

I was using bleachbit and system got hanged, so restarted. But after entering username and password, it does not go to desktop. So tried with tty, and here is the screenshot.

uuuhh, be careful with these so called cleaner, better remove stuff manually. If it removed config files from your system, you have bricked it.

1 Like

Can you please clarify whether you ran Bleachbit or Bleachbit-Root?

What your errors suggest is that /tmp is completely filled. The system in unable to write to it. This may be why you were running Bleachbit in the first place...

If you can boot into the Grub Menu, then select Advanced Options for Zorin you will see options for Zorin on 5.15... (recovery)
Choose Recovery and in the Recovery Menu, arrow key down to Root Drop to Prompt

In that terminal, bap enter or ctrl+d and run

sudo apt clean && sudo apt autoclean

sudo apt autoremove

Test booting and logging in to the desktop. If you still cannot login, we may need to purge all contents of /tmp

Tried above commands and no success. I ran bleach bit in root mode

Do you recall if you had the following items checked?

  • VIM swap files across system
  • VIM swap files under user profile
  • Custom
  • Free Disk space

What is the terminal output of

df -m /tmp

The /tmp directory should be cleared automatically at Boot, similar to how RAM is.

I just ran bleachbit for cleang, asked for password for .dstore cleaning and system hanged. So restarted. Happened this way

I tried ```
systemctl start gdm3


No command for installing gdm or light DM works

Good memory. That helps.

Ok your terminal output shows /tmp as 100% filled.
In your terminal, please run

sudo find /tmp -type f -delete

Then run

df -m /tmp

To ensure it is not filled to 100% anymore.

This is the current scenario.
What to do ?

I am guessing from that, that the

df -m /tmp

showed /tmp as no longer filled, so you proceeded to boot?

The screenshot doesn't show anything unusual... Is it slow to boot?

Screen stuck, no login screen or reboot.

What to do ?

Boot into the Recovery Menu again and look to the list shown. Select

  • dpkg

to run. That will essentially run the same command as dpkg --configure -a

  • clean

This will clean up files much like we tried already. You can click that one, too just to be sure.

  • fsck

This is a File System Check

Once you have run the three above, try booting normally.

1 Like

fsck does not work.

Help me how to reinstall the login screen gdm or lightdm. I think, I deleted lightdm.

Currently, this is the login screen after normal boot


That is important information.
Let's go ahead and ensure all our bases are covered...
From Recovery - to Drop to Prompt...

sudo apt install --reinstall zorin-os-lite-desktop

sudo apt install lightdm

Follow any prompts the terminal gives to setup / configure lightdm.

1 Like

Here is the output

I have lots of data on the desktop , I don't want to miss that. Please suggest such solution

I just typed startx on the terminal and this desktop came :grinning:

Ok, ensure Networking is Enabled,
then try the commands above.

No network manager or applet to open in root mode. What to do

Return to the Recovery menu
Arrow key down to Enable Networking
Once enabled, back up to the recovery menu and arrow key down to drop to prompt.

1 Like

Hi Thanks for your support. I reinstalled zorin core and also installed zorin lite desktop through command prompt. I selected gdm in the command prompt and looks good. But there are options to select zorin, xfce, zorin on Wayland, lite in the login screen. I want to keep lite only and don't want other options. What to do

Why did you install Zorin Core?

You can remove just the .desktop files for the other entries - but this would leave the Gnome D.E. and other Zorin OS Core components still installed.

The .desktop files are located in /usr/share/wayland and /usr/share/xsessions

1 Like