Zorin loading slowly for some reason despite using an nvme ssd on the newest intel cpu and motherboard

title says it all. I have no clue what's wrong

You might want to look at a newer kernel if you got the latest gadgets. There's a dozen thread regarding installing the latest kernel on Zorin OS on this forum.

Unfortunately I looked it up on the forums and found nothing about updating just stuff talking about the recent kernel

Works for 17 as well.

1 Like

okay thank you will read :+1:

Please let us know if it solves your problem.

So i Installed the latest kernel *6.9.3
and I have no clue what to do next

Have you rebooted?
Then you are good to go to test it.

followed all the instructions and rebooted and did an update/upgrade command and found that the latest kernel needs "Depends: libc6 (>= 2.38) but 2.35-0ubuntu3.8 is installed
Depends: libelf1t64 (>= 0.144) but it is not installable
Depends: libssl3t64 (>= 3.0.0) but it is not installable"

and i tested both programs and it really was uninstallable

Hmmm... that requires upgrading libc6 as well - which is not advisable to do so.

Did you tried installing the latest? Try some previous ones, as the latest might be build on newer libs.

Found this, you might want to test it:

it worked

but now theres an issue with my display
its stuck in 1920x1080 (16x9)
and calls my display "Unknown display