Zorin menu won't open with right super, left super is not an option

Hello everyone

I'm fairly new to Linux and I've taken a leap of faith this week by buying Zorin 16 Pro and installed it on my computer. Almost everything seems to be working really well.
But, I have 1 annoying problem trying to open the Zorin menu with the 'Right Super' key, it just won't open...

Adding some context: I have a Steelseries g6v2 keyboard, this keyboard only has 1 Super Key (1 on the right) and the one on the left has been replaced with the Steelseries logo and acts as a 'Fn key'.
When I press the Left Super or Right Super, nothing happens.

The only way I've been able to make the Zorin menu popup when pressing the Right super is by doing this:
1: Under Zorin Appearance -> Interface -> Left Super Key => Set it to 'Zorin menu'
2. Install Gnome Tweaks -> Open Tweaks -> Keyboard & mouse -> Change 'overview shortcut' from 'Left Super' to 'Right Super'.

=> This fixes the issue (the Right Super opens the Zorin menu, as I wanted), BUT everytime I restart my computer or if I lock my computer and log back in, the Gnome tweak setting I adjusted, has been reset.

Some extra info: I've tried an old keyboard that has 2 actual Super keys. The problem doesn't present itself here (Left Super works for opening the Zorin menu).

So the question is, how would I persist the changed gnome tweak setting so it doesn't get overridden everytime I login to my computer.

Kind regards
Thomas

Hi @mwthomas, welcome to the forum.

Sometimes shutting down doesn't save your session information (settings, background changes, custom keyboard shortcuts). Try setting things the way you want and logging out. Then log in and restart. Let me know if this helps.

2 Likes

Sadly, this does not solve the problem. After making the changes, logging out and logging back in the 'change overview shortcut' tweak has flipped again from Right to Left Super. Restarting also made no difference.

1 Like

Hi!

Same here; my keyboard has only a right-super (windows) - key. So I experience the same problem as mwthomas... I hope this can be fixed or a workaround for this, please.

Did you try Super + A?
It always works for me in Zorin 16 Core/Pro.

I use the Win11-like menu and with SUPER+A I get the Ubuntu-menu. But it is a very good alternatieve (works almost the same). Only super-r is not an option, I guess...
Thanks!!

Glad to hear that it does almost what you wanted :slight_smile:
As a former OSX (Hackintosh) user, I use a mac-like menu.

1 Like

In Zorin 15, or perhaps 12, alternate option was Alt+ F1. No such issues with KDE Plasma (it isn't Gnome). I have left and right 'meta keys' and both launch whatever KDE Plasma Menu I am using at the time! :wink:

1 Like

Nope, that's the activities-switcher (now). More ideas??? :smirk:

There used to be an option to switch between Activity Manager and Menu option. :wink:

It is still there.
In Zorin Appearance > Interface > Left Super Key
and click the drop down menu to change it from Activities Overview to Zorin Menu or the reverse.

3 Likes

Thanks for the confirmation! :wink:

2 Likes

Tried that, but still activities on both settings when pressing ALT + F1... :man_shrugging:

But that was not the solution for my problem, I guess...

Hmmm... I guess not. You are looking for a solution in regards to the Keyboard Shortcut.

Funny... on my desktop, alt+F1 brings up the right-click context menu.
On Zorin Gnome, what does the Keyboard Shortcuts dialog window show?

Actually no matter what I do, I never be able to make Super key to open application menu. It always requires Super +A.

Instead of torturing myself, I decided to customise my brain and now I've got accustomed to this key combination :nerd_face:

1 Like

I agree, but I have to use 2 hands for it. Wow, am I lazy or what...?! :laughing:


OUCH!

1 Like

Oh, you got Super key on the right!
I did not know there is such thing.
All my keyboards have Super key on the left pretty close to A.
This is what I use everyday.

Yup. That's why I asked for help. Zorin sees it as a right-super-key. There is no way to permanent set is as a left-super-key...

I wonder if you can change the alphabet A with other letters which is closer to this right Super key, such as L or K.

Great idea! Didn't think of that. But what is de command to open the zorin-menu?