Zorin OS 15.3 Lite not booting after installation

Hello guys, i found zorin os lite about a week ago and noticed that is pretty good with old CPUs so i wanted to install it on my grandpa’s PC and everything seemed to be good until the CPU couldn’t boot into the OS.

Video: Zorin OS Lite 15.3 Not booting after Installation

I did make the usb stick using BalenaEtcher and booted pretty fine into the installer. As the guide says, i choose the language, keyboard, update option and then the first option that says “Erase Disk and Install Zorin”. Everything installed pretty fine but once i saw the screen that says “Disconnect the usb and then press ENTER” i did it and the CPU rebooted but never booted into the OS, i checked on my BIOS and it is in Legacy Mode, also checked if the usb stick was fine and ran " Check installation medium for defects " and everything was pretty good

I need help because i really want to fix this PC for my grandpa.

Here some specs:

Motherboard: Intel DPT965LT Socket 775
Processor: Intel Core 2 Quad CPU Q6600 2.40Ghz Intel® EM64T Capable
GPU: NVIDIA GeForce 8600 GTS
RAM: 1x2048GB DDR2 667Mhz Single Channel
Hard Drive: SAMSUNG HD321HJ - 320.0 GB
BIOS: MQ96510J.86A.1715.2007.1202.0001 ATA/IDE Mode Legacy

Pd: This pc was working normally with Windows 7 Ultimate, the thing is that it was really slow and it doesn’t even is secure anymore

Welcome.
Please try Aravisian’s instructions here.
Remember to either hold left shift or tap esc repeatedly (you may have to try one method and then the next if the first doesn’t work).

It’s worth trying using a DVD of the .iso - for some reason usbs can be difficult on older equipment - if the PC has the drive of course.

1 Like

Sorry for taking to long to answer, pressing shift repeatedly or esc while booting up the machine, ends with the same result as the video shows…

Also the machien boots the usb stick with zorin os lite 15.3 pretty fine and installs the system fine. The problem is after the installation process, i eject the usb and reboot the machine and it doesn’t work

This looks like a Graphics Drivers issue. The USB Stick uses The Ubiquity Default settings, including ‘nomodeset.’
What you might try as a first step is boot up using your Working USB copy. Once booted and you have access to the drive, you can mount your HDD and installed partition of Zorin (use terminal mnt / command or use Gnome-Disks…), then edit your /etc/default/grub file on the line:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset”

Shut down, remove the USB and test booting up the machine. IF you are able to boot, then you can at least manage your installed graphics drivers and upgrade the kernel.

When i try to mount de partition using

$ sudo mount /dev/sda1 /mnt

I get the error

mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

Check that you can see your drive

lsblk

If so, run

fdisk -l

fsck /dev/sda1

Then try the mount command again

zorin@zorin:~$ sudo fsck /dev/sda1
fsck from util-linux 2.31.1
e2fsck 1.44.1 (24-Mar-2018)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks…
fsck.ext2: Bad magic number in super-block while trying to open /dev/sda1

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
or
e2fsck -b 32768

It’s weird because also tried a new fresh install hard drive and same results, should i install using something else option? how much space should i leave for each partition? thank you for your help

Hmmm… Are you using GPT with UEFI? How many partitions do you have?

I used the first option “Erase Disk and Install Zorin”. So the default partition table. I’m asking if should i use the Something Else option and manually create every partition

Ok, so by your answer and method- we are agreed that there should be only one partition on your hdd,right?
You See, non-gpt UEFI systems can only have a maximum number of Four Bootable partitions. UEFI systems can have more than four partitions, but only four partitions can be Bootable.

To use the Something Else method:
Select “Something Else” and a gparted instance will pop up.
Select the partition you wish to install Zorin on by clicking it in the window.
Then click the (-) Button on the lower left to Delete The Partition.
Now, that partition will show in the Main Part of the Window as Free Space. Select it as you had in the step above and click the (+) button to Add the Partition. A Format PopOver window will come up.
In that, you can leave everything as it is- But Important: Select your Mount point - I always select it as
/
Select to format and let it run - then follow the prompts.

Another question: On your previous installs, did you select “connect to the Net and Install Updates as you install”? If so- Don’t do that this time. Try not connecting to network and not updating or installing additional software as you go.

Thank you so much for your time. I appreciate it. The first time i installed Zorin OS Lite 15.3 i checked the first 2 options, update and install drivers, hardware, wifi, etc… The second time i checked only Install Drivers without checking update. The third time i un-checked everything and it didn’t work. Now i also unchecked everything and manually partitioned the hard disk

I followed a guide for correct partitioning ubuntu… I’m installing with these partitions:

ext4 /boot 512mb
ext4 / 15000mb
ext4 /home 87757mb
ext4 /var 8000mb
swap 4000mb

After finished i hope it works. If i doesn’t, i will try your installation method deleting everything and formatting to ext4 / (root i guess) only.

Hi again

I tried creating every partition manually and it didn’t work… Weird because i did mount every partition fine except /boot, always got error.

I also tried your method @Aravisian and it worked for mounting boot using

$ sudo mount /dev/sda1 /mnt

I edited grub using

$ cd /etc/default/
$ sudo nano grub

Saved and i did unmount the drive and restarted the pc but now i got an error message that says No bootable media found - Insert a bootable media and press any Key

At least i got something new lol help

Once again did a fresh install, formatted the hard drive creating a new partition table msdos and installed using something else option with only one partition as root ‘/’ without checking any of the updates and hardware options. Then before rebooting the system, i mounted /dev/sda1 using mount. I edited grub using sudo nano /etc/default/grub changed to nomodeset and saved it. Then i used

mkdir /cow
realpath /cow
ls -la /cow

Then

sudo chroot /mnt
update-grub2
exit
sudo umount /dev/sda1 /mnt

And rebooted the system. Everything seemed to be working because taked waay long to restart the system, like totally freezed at

_

Then never showed up any zorin just shutdown and rebooting again as the video showed

I just dont understand why

Btw, tried to edit grub again without installing just booting up with live usb and got this error again

mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

I do not understand how MS DOS has a role at this point; Can you help me understand more precisely? Are you dual booting alongside of Windows?

No i don’t, i just did that because if i try using gpt, the machine doesn’t detect any bootable device

No device detected – Insert a bootable media and press any Key

Is this an external HDD?
I am not picking on you- I am just confused and trying to help you out.
MS DOS cannot be accessed with Windows- Did you hook the HDD up to another computer?

It’s ok mate and No its not, its a simply hdd SAMSUNG HD321J

Tell me what to do and what logs do you need, because I don’t know what else to do

Have you tried Grub Repair (cannot boot)?

I still have no idea how you used MS-DOS to partition the drive if Windows is not on the drive and the drive was not hooked up to another computer.
These details can help troubleshoot.

Hi mate, it has to be something with the bios of my system, is it possible that it doesn’t support gpt? I tried everything again and same results