Zorin OS 16.2, showing brief errors before startup, on Dell XPS 9520?

From this it sounds like you have Windows OS on a drive, but the EFI partition containing the bootloader information was on the one you installed Zorin OS to.
Let's check:
Boot into Zorin OS
Launch terminal


Copy and paste the output from the terminal here to this thread.

If the Windows EFI Bootloader needs repair, you may be able to use EasyBCD to repair it, or you will need to boot a Windows Installation media LiveUSB, access the repair settings and attempt the automated repair. If the automated repair does not fix it, you can use the cmd prompts bootrec or bcdedit - A wlakthough on that would require more details.

Do you have a log file from the Grub Repair?

Grub repair log file - you mean the log file error code I see when the startup repair fails?

Is EasyBCD a command I have to enter in the command promt?

Here is the what I got from the terminal in Zorin OS after entering the command you listed.

When you run grub repair, it points you to the log file on completion whether the repair succeeds or fails.

That log file already displayed in the video I uploaded earlier, you can watch and pause the video whole the log file is displayed on screen.

You must have already seen my log file error code already, please tell me what I can try to do next.

If you're able to get into your BIOS settings - do you have any settings relating to RAID or AHCI? This one still baffles me.. but was just an issue with another user preventing boot.

Take a look, see what you've got - if anything, set that option to AHCI and then reboot, don't reinstall though that's already done; just see if you can boot after that..

I've already tried RAID, Secure Boot and AHCI and it still does not change anything.

Have you seen the Dropbox video I posted on here earlier before in full detail?

Rewatch it if you need to, take as long as you need to!

@Z_123, I watched the video and I did not see a logfile. The resolution is blurry enough that even if there was one that flashed on the screen, I doubt it would be legible. It certainly would not be the full log (which is a series of pages that must be scrolled through.

You can use pastebin.com to relay the full contents of the grub repair log file.

Hmm then I'm not sure how a log file looks like exactly...

I have had this issue for nearly a month now and I can't afford to take my PC to a repair shop or renew the warranty so I've got no choice but to try resolve this issue on my own.

That is why I am on here asking for tips and guides on how to fix these issues.

Yeah, I was the one that pointed out you weren't getting to a login screen :wave::smile:

So - did you try removing the Zorin disk from slot 0 and replacing it with the Windows disk - leaving the Zorin disk removed - then trying to get that working with only the Windows disk? I would absolutely start there.

Check this out:

That has some good stuff you can try - you may need to run the BCD repair. There are plenty of things that can cause this 'access denied' error. So, there are also plenty of fixes out there as well :+1:

Ok I've already physically removed the Zorin SSD and put the Win11 SSD in my 1st slot of my PC and it still shows the exact same screen...

I clicked on the Superuser link and none of it helps as does not mention anything about the exact issue I currently have.

What specifically do you mean by the 'same screen'? If you're talking about like in the video - that's as expected. Placing the Windows disk in slot 0 didn't solve any boot problems; they're still there.

Have you tried any of the startup repair options either automatic or through CMD from the installer after removing Zorin from the machine and placing Win in slot 0?.. Just booting from that disk is not going to work since boot is not working properly.

The linked post was to give some insight on others issues and what was used to fix their 'access denied' error when using bootrec commands - as stated in the title of the post. We're still troubleshooting what may be even causing this; and there also may be more than a few other commands that need to be ran along with the bootrec and bcdboot commands.


Pop your Win disk back in the machine, boot Zorin, mount your Win disk - backup any information of value to you, format the Win disk.. then reinstall Win and call it a day :+1: That doesn't give you any answers on why that was happening but, it won't be a problem after you reinstall Windows.. Last case scenario most times, absolutely not my preferred way but if it works for you, then it works. If you want to keep giving startup repair a shot - we're here. And no offense but, I for one will need more detailed info about what you were trying and in which way; complete syntax and all, errors received, error codes, etc..

(edit) Also - one thing I just noticed rewatching the posted video ..... You cancelled the system refresh once you chose to keep your files and reinstall Windows.. You may have done more damage there when cancelling the action. Just another possibility - which you would need to probably reinstall at this point, if that's the case. I did this with another machine and it completely messed it up until I removed all the power sources and drained every bit of stored voltage on the board (flash based storage device). Then, I was able to get somewhere, but only to reinstall; as all the data was corrupted..

I would absolutely mount your Win disk in Zorin and see if you can even access your files...

Mount my Win SSD with Zorin as in, putting back Zorin SSD in the 2nd slot of my PC?

If I resume the system refresh once again, will that help with anything?

Yes - then boot from your Zorin disk, mount your Windows disk in Zorin, then copy all of your data you have available that's important; documents, music, games / saves, pictures, etc.

That's just in case you can't get going with anything boot repair related.

You can absolutely try that - I have no idea if it will prove to be useful though but, worth a shot! Just think of it this way: If you take it to a shop - they're just going to format the drive, reinstall Windows, and then charge you an exuberant amount of money for something you can do for free..

Well I certainly don't want to do that so please tell me how I can start resuming the system refresh again?

The same way you did in the video; except this time from your installation media instead of the internal disk with the borked Windows install.

Installation media as in, a USB Drive or something?

Yes - you'll need to use the MediaCreationTool by MS to get your USB made, if not already done.

Here's the link from my earlier post #29:

Just select which Windows version (10 or 11) you want to use, download the tool, write the USB, then boot from it.

But do I really have to reinstall the OS from scratch?

I'd much rather find another way to resolve these issues.

Also, my SSD is NTFS and is write protected - in case you needed to know...