Zorin os 16.3 lite not showing wireless internet and icon, just showing Ethernet

I installed zorin os 16.3 lite because previously my system was corrupted, I installed with a usb which I don’t have anymore because my laptop broke it today, the same day I bought it (:man_facepalming:)

What is your terminal output for:

sudo lshw -C network

Description: Ethernet interface
Product:NetXtreme BCM5761 Gigabit Ethernet PCIe
Vendor: Broadcom Inc. and subsidiaries
physical Id:0
Bus info: pci@0000:03:00.0
logical name: en3s0
version: 10
serial: b4:b5:2f:da:cd:fc
capacity: 1gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list Ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=5.15.0-78-generic firmware=5761-v3.80 latency=0 link=no multicast=yes port=twisted pair
resources: irq:47 memory:ff610000-ff61ffff memory:ff660ffff (this took forever to type)

Broadcom considers their drivers proprietary. For this reason, distro suppliers cannot include them on the grounds that the distro supplier may profit from them.
But the user can install the drivers.
If you can connect using Phone hotspot or another means, open terminal and run

sudo apt install broadcom-sta-dkms broadcom-sta-source broadcom-sta-common bcmwl-kernel-source

(This assumes your wireless is also supplied by the Broadcom card)

I do not have my phone anymore it’s broken

Do you have the Possibility to use a Cable by yourself? Or maybe at a Friend's Home? Then you could plug in the Cable and download the Drivers that @Aravisian named You.

I think tomorrow I can use an Ethernet cable to download the drivers so I’ll try that

I can use it for a bit tho but it can work

Any chance to claim the warranty on it? You can trade it for an ethernet cable, and a USB adapter since a lot of computers don't have a port for it these days. I don't use it all that often to be honest, but having it around has been extremely useful more than a few times.

Probably not tbh but tomorrow I’m gonna try an Ethernet cable for the time being then I’ll install the drivers and hope it works

https://youtu.be/htx3c2xwL4g?feature=shared If u look below on the task bar beside the bell icon on the left u will see a tv looking symbol with an x I have that too

It says unable to locate package

When it gives this message, it states what the name of the package is that it could not locate.
Including that can be helpful.


sudo apt install bcmwl-kernel-source

Ok it seems to be installing

I tried that other command and it worked now it’s installing

Ok I did this and it installed now what

Also I can do this but idk how to properly set everything up I got bssid and ssid but I don’t know what to enter for the device and so on and how to make it actually work

Everything there looks fine. You do not need to fill in all fields.
Can you right click on your panel (taskbar) and under Panel slide over to Panel Preferences. Move to the Items tab.
Click Add.
Select Status Notifier Plugin and add it to the panel.

If you want to keep it, you can position it where you want on the panel with the up and down arrow icons on the right side.
Now, you should see a Network Manager Icon on the panel.
Left click that Network icon and look for your WiFi Listed under Wifi Networks. If it is present, click on it to connect to it.

I have 2 of those icons now I’m connected to Ethernet but it shows this