Zorin os 16.3 lite not showing wireless internet and icon, just showing Ethernet

Let's try a simple reboot...

I’m restarting it

1 Like

I had one of those monitor icons but now I have 2

Still the same

You can use the same steps to remove the extra from the Items tab in Panel Preferences.
Sorry about that - I was not sure if you had that plugin so walked through the steps of adding it.
Can you run

sudo modprobe wl

to see if the module prober activates the Broadcom wireless.

No problem

I entered it, it asked for my password and I entered that and then it did nothing

If it was meant to be wi then it says module wi not found in directory

Yes, it is wl

@PlumpKibbles has addressed this one before and I am not certain if the b43-fwcutter is needed. Maybe he can chime in when he logs in.
For now, let's try

sudo apt install firmware-b43-installer

1 Like

That’s installing right now

I’m gonna have to disconnect the Ethernet cable in a couple of minutes

1 Like

Ok it installed

I have to disconnect the Ethernet cable now I think I can use it tomorrow I’m not sure

No problem. We can resume later or PlumpKibbles can join in.

In the meantime, you might try rebooting and testing to see if the previous steps helped.

Yea I’ve tested that and it’s still the same so I’m not sure

The same thing happened in this video https://youtu.be/htx3c2xwL4g?feature=shared but he uses an Ethernet cable in a different video so I’m not really sure

What are the outputs of "rfkill list", "sudo dmesg | grep -i wifi", and "lspci | grep -i network"? (commands were edited in quotes to signify the whole command string)

Also what make / model machine are you using?

One more: when you did the install; did you uncheck the 'Install third-party software'? I've had some issues with drivers after a 'minimal' install myself, heh.. mostly Nvidia though.

I didn’t uncheck anything but I have a hp compaq pro 6305 small form factor

sudo dmesg showed a whole lot of stuff it also says error communicating to tpm chip and at the end it says File /var/log/journal/d70689194a0c4829b3bd9fcb47552aa3/user-1000.journal corrupted or uncleanly shutdown, renaming and replacing, rfkill list does nothing, Grep -i Wi-Fi is just doing nothing so far