Zorin OS 16 Core Slow Wifi TP-Link N900 (TL-WDN4800) Qualcomm Atheros AR9380

Good evening all, if i can trouble you with a wifi driver problem that I'm confronted with and cannot find a solution to. Basically my wifi internet connection is slow and unstable. Here are some speed tests done minutes apart:
2 megabits/s download 20 upload

second test
40 megabits/s download 20 upload

Details of my wifi adapter:

What I've tried so far:

  1. disabling ipv6 - no change
  2. disabling the 11n capability - no change.
  3. modifying the ath9k.conf file like this ```
    sudo su
    echo "options ath9k nohwcrypt=1" >> /etc/modprobe.d/ath9k.conf

increased the speed from 0.5 megabits to about 50 megabits but it didn't address the stability problems.

My windows machine and MAC always go over 200 megabits as per test below.
215 megabits/s download 20 upload
Please help?!!!

Enter your terminal...

sudo apt-get install firmware-atheros
sudo modprobe -r ath9k
sudo modprobe ath9k

Reboot your computer and let us know how it goes.


Your Tech Support Guru

1 Like

Package firmware-atheros wasn't found, and wifi is not working at all now. It shows connected but there is no internet.

This is extremely odd, its acting like there is no sources list from the repo for said drivers. Does this work?

apt-get update && apt-get install firmware-atheros

If this doesn't work then I am officially lost.

Main server?

Aravisian is right, did you switch your sources from your countries to Main Server? See how mine says United States? That part, change that to MAIN SERVER.
Screenshot from 2021-10-14 15-00-34

I think this settings are correct:

Just to putt all in here maybe it may help somebody else: after the modprobe -r ath9k to get the internet connection back i had to forget the network and set it up again.

The server in the Software & Update was different but now changed to Main Server but still the package can't be found. I even got myself in sudo su mode.

I am not sure if you actually need firmware-atheros... but give me a moment and I will get it in a .deb format that you need only double click to install.


From debian nonfree sources.

I'm getting this error:

Reboot the computer and try again please.

I tried restarting, but to no avail same error. I moved file AthrBT_0x01020001 from ar3k to see if it make a difference but still the same error.

In that case, it appears you do not need the package as the files are already included in the Ubuntu "linux-firmware" package that you already have installed.

I'm going to turn in because it's getting late. If any other ideas please leave a post, I'll bash my head against it tomorrow. Thanks and really appreciate you guys help.

Had you tried disabling Power Saver?
Find your Wireless I.D. (wlp3s0 or wlp2s0 or wlan0...)


Replace (network) with what you found above:

sudo iwconfig (network) power off

Tried it now but looks like it doesn't support power management.pow

This does not surprise me... it was worth a shot. But that suggestion is iffy.
Let's try it manually:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the value of wifi.powersave = 3 from 3 to 2 to turn it off:
wifi.powersave = 2

Reboot needed for it to take affect. Or sleep. :wink:

no change in internet speed.

The funny thing is that Zorin OS is dual boot, and the same machine hosts windows as well. If i switch to Windows the internet speed is past 200 megabits, so it's clearly the drivers.

1 Like

Have you modified your grub file at any time?

sudo nano /etc/default/grub


I haven’t made any modifications. Problems with internet connection have been from day 1. I’m not home now but will give that command a try and post later.