Zorin OS 16 Experience

Hello there! Here I'll leave my remarks regarding my experience on Zorin OS 16.

Here are my laptop's specs
Model: Dell Inspiron 1545
RAM: 4GB
CPU: Intel Core 2 Duo T4200 (2.0GHz)
Space: 16GB USB Drive (I know this is low but I don't download that many apps and currently have 5GB+ free space)

Experience
Post 1:
It's been a single day since I installed Zorin 16, so far it runs very good without issues. Sometimes there are a bit of lag spikes but I'm okay with it. The animations seem to have minimal effect on performance surprisingly (compared to Windows Aero) It uses about 1.1GB of RAM on idle so i still have plenty of Ram to work on. Also, I've been using Zorin 15 Lite prior to this and also surprisingly, performance is on par (for now)

4 Likes

Post 2
So far still good, but there's a few bugs/ annoyances
#1
When booting up, I get a black screen and it does not boot at all. I have to force shutdown my laptop and when i switch it on again, I get this panel which i then can boot to Zorin (Image not mine-also no win10 in my pc)
image
#2
The month in the taskbar is Arabic (probably because I'm in an Arab country) and there's no option to change it. This was a problem in Zorin 15 too.
image
#3
The 2nd thing that annoys me is that bluetooth is always switched on whenever I boot up. Same problem in Z15
#5
Another bug (probably) I've noticed is, when in the software store, if you try to delete multiple apps (like clicking remove after one another), you sometimes don't get the authentication popup and it shows an error telling me that i don't have perms.
#6
Idk if its been added yet, but there is no shutdown animation

Suggestions:

  1. The sound when the tour app opens is too high and pitchy, try fixing that
  2. The boot animation would probably look better if the word "Zorin" was centered
  3. Maybe a guide for completely new users on how to use Linux, how it differs from Windows, etc
  4. Automatically disable some features if a PC's specs are low to maximize performance

That's it! Thanks for reading! <3

1 Like

Others have mentioned this happening. I need to get some other work done for now, but you may try searching the forum for this issue and see if / how that was resolved.

Can you remove blue-man from Start Up applications?

Long standing issue with the Software Channel. You have to use small words with it and speak kind of slow. The "solution" is to remove an app one at a time and don't overload the poor thing.
The Software Channel is developed and maintained by Canonical, not ZorinGroup.

It is present - mine shows up. I wonder if this is related to the First issue you mention (Boot up failing the first try).

Agreed. Actually, I just installed the Zorin 15 Plymouth and then changed to it instead. I prefer it by far over the Z16 Plymouth theme.

The tips here may help:

1 Like

Great, so my points are valid, I've got a few more bugs and issues which I'll list in Post 3 soon

2 Likes

Would love to have that animated Zorin display when booting up. Like when you boot up the live image of Zorin. Now I have my motherboard brand showing instead which is okay... I think :stuck_out_tongue:

For me, the motherboard logo (actually in my case the laptop brand) shows up with the Zorin loading animation below it similar to how Win10/Fedora boot up. It's pretty slick. I'm surprised that you only see the motherboard logo.

Could it be because I have a nvidia card with binary driver? In the paste (way back) the bootup screen wouldn't show if you have binary driver loaded.

Post 3
#1
If I am in full screen and hit the windows icon to open the menu, it doesn't appear where it should be also it should show the full taskbar right? It doesn't. It's very annoying when I'm doing classes/watching movies.


#2
I have edge scrolling for my touchpad on, and it switches itself back off after every boot
image
#3
Probably unrelated, but whenever i do Zoom Classes, i get 80+ CPU usage sometimes even reaching 100. Task manager shows it using 22% and gnome using ~20%. Rest are very minimal like ~1-2%. I have no idea why.

#4
In the software app, when selecting "Flatpack", it stays on "preparing" for a veryyy long time. When i switched to Zorin repo, it was much much faster

Suggestions

  1. When installing, users can make a selection of apps they want included, such as ability to install Firefox or Edge, or if we want the games included.
  2. Maybe, if its possible by Zorin devs, add something like a troubleshooter which is present in Windows.
  3. PLEASE PLEASE simplify the update options, when i get an update popup, i get a heck ton of lists that I have no idea of. I even still get updates for apps like Firefox.

Just some thoughts, Linux still feels a lot less user friendly compared to windows, though using Zorin has simplified this a lot. Like almost everything a bit complex involves using the terminal.

2 Likes

@Storm @Aravisian @zabadabadoo @FrenchPress

Sorry if you were disturbed by the tagging.

I would love you guys input on the post above. Thanks!

I avoid Gnome as much as possible and so am even more of a novice on Gnome than anywhere else.

Can you try disabling Two Finger Scrolling, first:

gsettings set org.gnome.desktop.peripherals.touchpad two-finger-scrolling-enabled false

Then enable edge scrolling and reboot and test.

This issue is with Flathub, sadly, and not within Zorin OS control.

It is known that Zoom is a CPU hog most often in Linux Distros and performs better on Windows. Partly because Windows is the Dominant OS in the market; Zoom is designed for it. Some have had some luck in disabling hardware acceleration to get Zoom under control. Others had some luck by changing their kernel. But this is a common problem with Zoom, there are open tickets with the Zoom Developer that are simply Standing.

EDIT: I am logged into Zorin Gnome Desktop now and performed a Common Test: I ran a YouTube video. It shows lag and hesitation that is not present in XFCE or Cinnamon Desktop on Zorin, but is present in Gnome Desktop on Zorin. This suggests that Gnome-Shell is the culprit.

https://ubuntuforums.org/showthread.php?t=2444273

My PC hardware already doesn't support that so it's not there

Lmao, so relatable. Even my friends on Windows complain about high CPU usage. I myself too get high CPU when running Zoom but not the level on Linux. Probably cause it's less optimized

Removing the Firefox Language Packs using Synaptic Package Manager will easily resolve this issue.

2 Likes

I use Bleachbit to eliminate all those languages I would never use in this lifetime :wink:

1 Like

I am not running Z16 so did not contribute earlier. However, Re language packs etc, this thread may help:

Tagging @azorin and @zorink as I have also noticed some peculiarities with Zorin 16 Gnome Desktop.
It's slowed down, significantly.
Earlier, in looking at another users issue about Zoom, I did a test on (Gnome) Zorin OS desktop by running a standard youtube video in FireFox browser. I had only two tabs open at that time - As I had just logged into the Gnome Desktop. The video would lag out about every twenty seconds.
This piqued my curiosity, so I started repeating the tests I performed on Gnome when Zorin 16 Beta was first released. While it was blazing fast then (opening as much as Twenty Images in Gimp in a blink), now it hesitated heavily, taking a full two minutes.
I had not noticed this until now, as I had installed XFCE 4.16 on Zorin OS Beta and Cinnamon, which are my Primary Desktops. In those, Zorin is still as fast as normal.

1 Like

I might have missed something but I thought you can disable M/B logo display (splash screen) in BIOS. I always disable it on my system.

1 Like

On the laptop I'm using at the moment that have an Intel video card there's no problem showing the Zorin logo at boot up. But with Nvidia cards = No Zorin Logo.

Ah, I see.
I did not know that since I only have either discrete GPU or integrated GPU. It seems that the hybrid GPU could be a (major/minor) headache in both Linux and Hackintosh.

In looking up how to do this on my machine, I also found how to remove the Manufacturer (Big ugly green thing) Logo with EcoSmart on the Monitors, as well. So a double whammy of helpfulness, this one.
Powering on Monitors goes straight to the desktop now with no splash (or delay at all) and the boot goes straight to the Zorin OS Splash Screen (I use the Zorin 15 splash on Zorin OS 16, because I prefer it.)

Nvidia drivers have not loaded yet. You may need to add the grub parameter GRUB_GFXMODE with the right value (I don't know what it is off the top of my head) or add GRUB_GFXPAYLOAD_LINUX=keep, then update grub and test (When your computer is working).

3 Likes

Sometimes the solution appeasers in a completely unexpected context. One of the reasons I hang around this forum :wink:

1 Like