Zorin OS 16 Lite Laptop cannot connect my external microphone

Hello, I'm new to this whole Zorin and Linux thing, I have this laptop which only has one audio jack, and I've been trying to connect my external microphone to it, with no luck making it work. I tried connecting it solo (I believe it is what people call TRS) and with a splitter cable (which should be TRRS, I think). But my laptop never recognizes the microphone. I've seen people suggesting to use hdajackretask, and I did use that to change 3 pins to microphone but it still doesn't work. I've tried alsamixer too, removed the mutes and changed all the volumes to the maximum value. And now I'm kind of lost with this thing, maybe it is an issue with the cables?

I also used this script to get some information about my audio codecs, pins and stuff:

Can you please post the terminal output for

sudo lshw -C multimedia

Sure, thanks in advance for helping!

description: Audio device
product: Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
vendor: Intel Corporation
physical id: 3
bus info: pci@0000:00:03.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:33 memory:f7c34000-f7c37fff
description: Vídeo
product: BisonCam, NB Pro
vendor: Generic
physical id: 8
bus info: usb@3:8
version: 6.05
serial: 200901010001
capabilities: usb-2.00
configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
description: Audio device
product: 8 Series/C220 Series Chipset High Definition Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 05
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:34 memory:f7c30000-f7c33fff

Drivers all look good...

Can you kill pulseaudio and then remove any exiting configurations for it:

pulseaudio -k

rm -rf ~/.config/pulse/


Install pavucontrol if you need it

sudo apt install pavucontrol

Plug in your BM-888 mic, then launch pavucontrol:


Go to the Input tab and check the drop down tab to see if your mic is listed.
If it is listed but not selected, then please select it.

Pavucontrol does say my microphone is plugged in. However it is not detecting any sounds. I tried with some online mic tests and a recording software like Audacity and Zoom, but no sound is being recorded. This is with the splitter cable on, should I try the microphone by itself?

Yes, you can.
On the Input tab, does it I.D. your mic?
For example, mine shows "Pyle USB Microphone Mono"

No. It just says "Microphone (plugged in)". The weird part is that it keeps saying that the mic is plugged in even after plugging it out. I wonder if it's because of hdajackretask overriding 3 pins to microphone?

Is this a desktop with external monitor?

I have a desktop tower- two monitors. I have one webcam due to the need for having to use Zoom... I have NVIDIA GPU
The monitors both appear to have built in Mics - these are listed as Front Mic.
The Webcam has a Built In mic, too.
Since I have Nvidia, both of the Above Mics will pass through the Nvidia GPU which is where they show up.
You may have something similar going on where something else is being recognized as a jacked in mic.

No, it's a laptop with only one audio jack. There is only a keyboard connected, no mouse, no monitors, nothing else.

1 Like

Let's double check:


Can you post a screenshot of the open terminal with Alsamixer settings?
Be sure to click the Arrows On The RIght Side if needed and capture that as well.

sure if it sets as fallback as in pictue: click on the icon of set as fallback.

That is pavucontrol
Can you please show alsamixer?

Sorry for the late answer. Here are the screenshots:
This is the first screen, I believe this part is not important

This is my Alsamixer setting

I have clicked that button a couple of times, I still don't understand what it really does though.

it was inactive , and u activate it?

No, after rebooting the machine the button was inactive.

ok choice ur mic and mark it as default mic by click on that icon beside it

Yeah, I activated it but I'm still getting no sound from it. Hopefully it's not the mic that's broken.

@thiviscar what Graphics card to you have?
Is it just Integrated or does your Notebook Computer also have a Dedicated Graphics card?

It's integrated. Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 86). It's quite old, which is why I chose to install Zorin Lite to it, because Windows 7 wasn't running very well on it. But I still have it as Dual Boot.