Zorin os 16 usb not showing as a boot option

i have been trying to install zorin os 16 on this uefi laptop but its not booting up.
i have already adjusted boot options in bios settings and disabled fast boot.

i have also been trying to boot zorin os on an older laptop that has both legacy and UEFI bios options . Please help me here on this post

Uefi/legacy dell and acer - Installing Zorin OS - Zorin Forum

A post was merged into an existing topic: Uefi/legacy dell and acer

since this topic is about uefi and not legacy lets actually talk about it

so this laptop acer has windows 11 insider build-runs same as 10 btw. 4gb ram 500gb HDD intel celeron uefi bios

so i tried booting zorin os edu 64bit using unetbootin without usb and it did not work aying some file is missing.

than i tried universal usb .... to my 128 gb usb and selected it on the boot manager but it ignoed and jut booted into windows

There are a couple of different possibilities including the ISO download being corrupted (net drop during download) or if "Persistent" was selected during the burn to USB by Rufus or Unetbootin.
Without you having access to the machine to test it, it is hard to know for sure.

i didnt use any download managers whatsoever

1 Like

oh i am now talking about a different machine that i have access to

i didnt select persistent partition

after it finished i just rebooted and select usb on the boot menu but it ignored and booted into windows

First thing I would try (Should be the same for Win 11):

On Windows 10, boot into UEFI settings as follows:
    Open Settings
    Update and Recovery
    Advanced Startup > Restart
    Advanced Options
    UEFI Firmware settings
Go to the boot tab of the UEFI settings
Move the Linux bootloader (GRUB or reFInd) above the Windows 10 bootloader (instructions to do this are usually at the bottom of the screen)
Save and reboot

You may try this guide if there is a file missing:

in the uefi boot tab settings there is no uch thing called linux bootloader or grub. only wibdows boot manager, usb hdd, usb someting

the problem now is even if i use rufus, universal usb, unetbootin nothing works, it just boot back into windows

so far i have used zorin lite 32 bit 64 bit
zorin education lite 64bit
zorin os core 16 beta

You wouldn't see Grub or Linux Bootloader in the UEFI settings.

If you are Booting alongside windows, you need to disable Secure Boot in the UEFI settings. Then boot into Windows, go to the Windows Control panel and search around for (I am not sure of the exact path and they keep changing it anyway) Fast Boot. I think it is under the Power Settings. Disable Fast Boot.

i have already disabled fast boot and also i need to set a supervisor password to turn off secure boot

It is not essential to turn off Secure boot - it just helps. Secure Boot can create conflicts. It helps to Narrow the troubleshooting.

A long-list of Bootable USB not showing as Bootable:

i think thats the wrong link???

1 Like

Yes... it is... And I never visited that page. That is very weird.
I will try again (EDIT: it did it again. Something about F2 on Plasma... I no-parsed the link and now it is working. Very strange.):
live usb - Why Doesn't a Bootable USB Boot - Ask Ubuntu

1 Like