Zorin OS 17 boots into black screen after fresh install

i installed Zorin OS 17 with the 17 Beta-iso (the 17 core did not boot) and everything worked fine on my PC:
Intel NUC12SNKi72 with Intel® Arc(tm) A770M Graphics, 64 GB, 12th Gen Intel® Core™ i7-12700H × 20, SSD NVme. I had a screen resolution with 3840x2160. Sound, Bluetooth, ... everything seems to work as it did before in the Live-iso. After finishing the installation the PC did a reboot and then there was just a black screen. Every time I boot that is the same. I can do following workaround:
power on the PC, press F10 to interrupt bios and get boot menue, then I select here the ssd (just these one is an option) and press immidiadtly ESC to get the grub menue. Here I select the second ( kernel and then it starts very quickly and I am on my system.
I tried "nomodeset" parameter in grub, but this was not useful.
Has anybody an idea how I can start "normally"?
Thankx, and a happy new year to all of you!

Do you have secure boot enabled in your BIOS settings?

Was it a total black screen, or do you have flashing cursor?

Do you know if Software Updater ran and updated your working Z17Beta to Z17Core. Maybe you did not notice the update or maybe updated to a new kernel.
If an older kernel works, but latest does not, you should be able to set to always boot the previous kernel. There are posts on here that describe that if needed.

I am thinking your problem could be similar to this (but this time Z17): Zorin core upgrade/reinstall booting to black screen

Check your ZorinOS version using neofetch

Secure Boot is disabled. It is a totally black screen, no cursor and I think the system is running in the background. In my opinion the software-updater did an update to 17Core.

I checked the Link that you posted to me. I always boot in my workaround in the second kernel, but I must do this everytime on my own. I tried to load the ( kernel by default with the following grub parameters:
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

But this did not help

Intel Arc graphics are very new - you might try the latest available kernel.

how do I get the latest one?

I prefer the TuxInvader Repo:

Others prefer Liqourix.

1 Like

Thank you for the ppa. But if I try to add it and install kernel I get this message:

sudo apt update && sudo apt install linux-generic-6.0.6
OK:1 Index of /ubuntu jammy InRelease
OK:2 Index of /ubuntu jammy InRelease
OK:3 Index of /ubuntu jammy-updates InRelease
OK:4 Index of /ubuntu jammy-backports InRelease
OK:5 Index of /tuxinvader/jammy-mainline/ubuntu jammy InRelease

How can I install this kernel? I am very new on linux
Ign:6 Index of /tuxinvader/lts-mainline/ubuntu jammy InRelease
OK:7 Index of /ubuntu jammy-security InRelease
OK:8 Index of /zorinos/apps/ubuntu jammy InRelease
OK:9 Index of /zorinos/drivers/ubuntu jammy InRelease
OK:10 Index of /zorinos/patches/ubuntu jammy InRelease
OK:11 Index of /zorinos/stable/ubuntu jammy InRelease
Fehl:12 Index of /tuxinvader/lts-mainline/ubuntu jammy Release
404 Not Found [IP: 2620:2d:4000:1::81 443]
OK:13 Index of /stable/ jammy InRelease
OK:14 Index of /patches/ jammy InRelease
OK:15 Index of /apps/ jammy InRelease
OK:16 Index of /drivers/ jammy InRelease
Paketlisten werden gelesen… Fertig
E: Das Depot »Index of /tuxinvader/lts-mainline/ubuntu jammy Release« enthält keine Release-Datei.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).

How can I install this kernel? I am very new in linux

Sorry I did a mistake. Now I could install the 6.06 generic kernel. But this did not solve the problem, I get a black screen after reboot.
Where can be the problem?

1 Like

Try adding the nomodeset parameter... I am not confident at this point, but it is worth trying. If no luck, revert back to not using the parameter by repeating the steps to add it to grub file, but backspacing the parameter, save the file, then run sudo update-grub before rebooting.

I tried the "nomodeset" Parameter but this didn´t help. Now I put following parameters to grub:
This boots the older kernel 6.2.0-37 generic by default and here everything works fine. But what will be in future? All the newer kernels are buggy on my system? Shall I deinstall the other (newer) kernel linux-image- 6.2.0-39?
Thank you Aravisian for your patiently help!

A new kernel can come with a regression. In this sense, rather than progressing, the kernel regresses. This is usually unintentional.
Like any bug, a regression is not common. We need to be wary of mistakes, but also bold enough to test new kernels.
Fortunately, you can always fall back to the previous working kernel, as you have done.

If it is not working, then, yes, you can remove it so that you do not accidentally boot into it.

Okay i will remove the linux-image- 6.2.0-39 kernel and hope a better kernel is coming in future. Thank you!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.