Zorin OS boot issue

I don't know why but when I booted my laptop, it stucked at zorin OS welcome screen and not responding anything. And it is dual booted with windows, so please help with issue...

Did you perform a 'shutdown' in Win before going into Zorin? I have one heck of a time if I don't actually do a shutdown before booting Zorin - lose sound, smells funny lol jk, but it acts weird..

Try booting into Win, don't login or anything - just do a shutdown, then power on and go into Zorin. If that doesn't work - do you know how to get into a different kernel from the Grub menu? Maybe try the previous kernel if it still doesn't boot - might not like something about it, if it is from a kernel update.. I'm betting Windows playing games though.


The windows trick didn't work, and I don't know how to do that.
And yeah, when I am clicking on zorin, I am seeing this too:

1 Like

Gotcha - so when you're booting you should see the Grub menu. Scroll down to Advanced Zorin Options in the list:

Then, you'll see:

You'll want to scroll down to the third option if you have two kernels installed (normally two are installed for safety netting), but not the (recovery mode) ones.

That will boot the previously installed kernel - if that works, there may be an issue with the newer kernel.

Just a thought - you haven't enabled Secure Boot in BIOS have you? Double check - that will prevent booting as well. (edit) BIOS updates may play with settings when updated too - have had this happen in the past..

1 Like

It booted up after loading that .87 generic kernel. So, ig I have to rollback to my previous kernel or it has a solution for this?
And yes, my secure boot is disabled.

1 Like

You can edit your Grub entry for now, I'm trying to find the post that's better suited for this.

For now though, you can edit your Grub menu to load the previous kernel by:

sudo nano /etc/default/grub - enter password, then you'll need to scroll down with the arrow keys to:

Screenshot from 2023-11-04 01-26-33

First few lines of the Grub options - GRUB_DEFAULT=0 Can be set to GRUB_DEFAULT=2, which will be your 'third' entry from the kernel list from before when selecting kernels, the .87 one. Now, use Ctrl+O to write the new lines, Ctrl+X to close the nano editor. Important step: run sudo update-grub to make changes take effect.

I'm finding the post on how to do this so you won't have issues when the kernel updates - but this should work for now. The 'grub_default' entry is much like disk numbering, 0=1, 1=2, 2=3, etc.

Found it! - [HOW TO] set an older kernel to default boot

1 Like

I did it, now what about that .88 kernel one? should I leave it as it is?
And Thanks for your help buddy...


No worries! :grin:

You can leave it installed for now yeah - there may be some mitigations that are preventing something from going through.. You can inspect the boot log in /var/log/boot.log - it will be looooong though, very long lol That should have some boot logs and time / dates - that may have some hints to what's holding up the .88 kernel; look for [failed] statuses, that'll be kind of pointing to what's not going through.

i went on that location and saw this:

Oh, yeah that's a sys location, should have specified that's on me. In terminal issue sudo cat /var/log/boot.log and that should ask for your pw, then spit out the contents.

cat /var/log/boot.log

Will also work without elevating using sudo.
It looks like the user tried using a GUI method in post #9.

1 Like

Definitely missed the txt editor window - I flew right past something in another post I fixed recently as well :face_with_peeking_eye:

tried it and it's showing me this:

Your screenshot shows what looks like the Verbose Print from the Boot screen.
Can you please clarify what "it" is that you tried?

actually I types sudo cat /var/log/boot.log to see what error does it show. And I got this with a failiure and I guess it's the GPU issue(Nvidia one) I was having it earlier.

What is your terminal output for:

sudo lshw -C video

showing me this:

Interesting; it shows Nvidia, but does not show the Driver Selected under "Configuration."
In Software & Updates under the Additional drivers tab, which Nvidia driver are you currently using?

here is the screenshot:

I am tired... I am sorry... I meant to also ask in my previous post "which Nvidia card you are using?" (For example, I am using RTX3060).
I am doing too many things at once...

You are using the 525 Proprietary driver which is pretty stable and solid (It is the same I am using.)

If you tap alt+F2 and enter in and run


Does a pop up window appear with all of the Settings listed (If it is not working properly, it will give a popup window that is titled, but blank of any settings.)