Zorin os breaking the time?

Hello! i dual-booted Zorin OS with Windows 10 a few months back and so far its been great, but there is a issue with the time. Whenever i go into zorin os and log in the time is 2 hours wrong, so if its 14:00 it would say 12:00. In zorin os it would automatically correct it self but in windows i have to go into settings and manually sync the time. Im just wondering why its happening and if its fixable?

1 Like

Well, interesting. In my case, it goes about 3 days forward. Surely due to our different timezones.

Strange that you have to sync time manually on Windows, I supposed that nowadays any device has the time auto-sync feature.

Yes. I have been doing that. Windows 1 hour incorrect. Zorin is always correct. Time-zone and DST set correct on both OS.
I just change Windows network time source which corrects the error (until next boot).

As I only boot windows infrequently I have been living with it :mantelpiece_clock:

run this command in the terminal timedatectl set-local-rtc 1 --adjust-system-clock
then boot into windows (time wont be correct this time) then disable and re-enable the set time automatically option in the settings
and ur done!

1 Like

try doing this

Set time automatically is already checked in windows but the issue still keeps going,

Happens to me too - I just sync time and go on with life lol I've always thought that somehow it changes BIOS clock settings? My old laptop would do that in BIOS after being in Linux for some reason.

I haven't tried, just thought about it - setting the NTP sync service on start for a delay (in win)? If that's possible..

@nfratom 's posted solution should do the trick. This issue has been raised on the forum before.

Here is a guide that confirms the command - but also gives a detailed explanation as to the cause; for the curious:


Here's a fix on the Windows side that has worked for me. It's a very easy regedit hack:

u have to disable and re-enable it even if it was already enabled

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.