Zorin Os Can't Change Screen Resolution its Fixed in (1024x768)

Hey Guys,
I am New to Linux I tried Several OS but found zorin to support my Hardware like AMD but when i installed it I have to Use nomodeset in boot to start the zorin and my screen resolution doesn't change its fixed in 1024x768 when my display supports 1600x900

My PC specs :-
AMD a6-7480 inbulit-graphics processor
no external graphics card

Here is my xrandr Output :-
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*

Here is my uname -a Output :-
Linux Jarvis 5.13.0-52-generic #59~20.04.1-Ubuntu SMP Thu Jun 16 21:21:28 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

I also tried to change the grub gfx mode /etc/default/grub
and setting new xrandr resolution but nothing worked

Anyone Help would be appreciated.

Sad to say I think your graphics hardware is the issue:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.