Zorin Os lite Can’t Change Screen Resolution its Fixed in (1024x768)


Hope everyone is doing great!

Somewhat new to linux but im having a headache with this issue after trying many things nothing is working so i need some help.

Firstly everything i tried:

Secondly My computer specs:

inxi: CPU: Dual Core Intel Celeron N2830 (-MCP-) speed/min/max: 631/500/2416 MHz Kernel: 5.15.0-76-generic x86_64 Up: 1d 16h 50m
Mem: 2263.4/3797.8 MiB (59.6%) Storage: 111.79 GiB (61.5% used) Procs: 209 Shell: bash 5.0.17 inxi: 3.0.38

inxi -G: Graphics: Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display driver: i915 v: kernel
Display: x11 server: X.Org 1.20.13 driver: modesetting unloaded: fbdev,vesa
resolution: 1366x768~60Hz, 1024x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.2.6

I am using a 19" Monitor with a VGA Cable, I know this monitor is capable of going a higher resolution because with my windows machine it is able to go higher up to 1280x720 (the highest i have used it)

Additionally when i run xrandr here is the results:
VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.00*
800x600 60.32 56.25
848x480 60.00
640x480 59.94

And when i run xrandr to set a resolution nothing happens so i am not sure where the issue. Any help would be appreciated.

Have you tried the specific command:

xrandr --newmode 1280x720 74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync



and see if you are VGA1 or VGA0
Let's say it is VGA0:

xrandr --output VGA-0 --mode 1280x720

If it is VGA1, then make it VGA-1 in the command above.

1 Like

I ran

xrandr --newmode 1280x720 74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

And i get this reply

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  31
  Current serial number in output stream:  31

And after running

xrandr --output VGA-1 --mode 1280x720

I get

xrandr: cannot find mode 1280x720

Are you using Nvidia card?

I dont think so i am using the integrated graphics on my laptop

I am using a Toshiba Satelite C50-B0488

Are you using a custom font in your terminal or system or all default fonts?

Using default fonts being

Interface Text: Inter Regular 10
Monospace Text: Jetbrains mono regular
Legacy Windows Titles: Inter Bold

As goofy as this may seem...
Try installing the xorg fonts

Run in terminal:

sudo apt update && sudo apt dist-upgrade

Then try copy and pasting the above --newmode and addmode commands again...

Alright will try this and let you know if it works

Yea its not working same response

Corrupted file, maybe?

sudo -i



If thosefiles exist, replace them with the above commands.

Then try setting the new mode...

How do i check if the files exist? or do i just paste it?

Just run as in the above post.

A warning... it is well after 2am here and my brain is starting to implode.

I have been searching for clues and found this:

You may need to roll back the kernel. In the meantime, please tap ctrl+h while in your home directory in your file manager. This will reveal the "hidden" files (ones with a . in front of them). Please check if you have a file called .xprofile

No worries even though the issue is not solved you have indeed helped me a lot and i do not have a file .xprofile but i do have one called .profile and .Xdefaults

Then I think the two links above apply... a fault in the driver.

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Reboot and tap esc or tab if using EFI boot to enter the Grub Menu or Hold Left Shift if using MBR boot to get the grub menu.
In the grub menu, select Advanced Options for Zorin
and select the Zorin on 5.8 kernel to boot and boot up.
Double check that you are booted into 5.8 and not 5.15

uname -r

Then try running the above --newmode and addmode...

Alright will do after i do that will let you know, let me start up a second computer so it will be easier for me.

1 Like

Yeah slight issue...I do not see 5.8 me 5.15 adn recovery mode but twice so it will say 5.15,5.15(recovery),5.15,5.15(recovery)

When you ran the sudo apt install command, what output did the terminal show?

Ahh i realise now i didnt run the command like you said, sorry let me try that real quick, sorry man yesterday i was running on no sleep.

Sorry man after going to 5.8 and trying the --newmode command it gives the same error, can you show me how to install the drivers maybe?