Zorin OS downloads failed under Windows 10

I'm trying to download a copy of Zorin Lite (15.3) to my Windows 10 Pro (build 19044.1387) laptop so that I can flash it to a usb stick in order to try it out. I can't download the file because windows is giving an error message saying the iso file type isn't recognized, and the copy of Balenaetcher I downloaded won't open completely for me to see what it looks like. This whole epic fail may be the fault of some recent Windows 10 update detail, but I can't be the only one having this problem. I'm not an experienced Linux user, so getting packets etc. isn't going to happen...

Hi and welcome to the forum :slight_smile:
I highly recommend using Rufus to flash USB in Windows.

I just checked the official download site for Zorin 15. It was downloded fine on my side.

PS
I edited the title for clarification.

1 Like

I downloaded Rufus as well, but it couldn't do anything because it had no downloaded iso to work with. The lengthy file name of the current iso may be the issue, but not my area of specialty.

I'm specifically trying to download the Zorin Lite 15.3 iso, the only version my spare tablet can use if I choose to use it on that machine.

32 bit?

You can also downlod it without browser from Windows CMD.

In the search box, type CMD and open the command prompt.

Paste the following command.
It will download the file in question to your personal directory with a file name zorin15.iso

For 64 bit
curl https://mirrors.edge.kernel.org/zorinos-isos/15/Zorin-OS-15.3-Lite-64-bit.iso -o zorin15.iso

For 32 bit
curl https://mirrors.edge.kernel.org/zorinos-isos/15/Zorin-OS-15.3-Lite-32-bit.iso -o zorin15.iso

I just tested it myself and it works.

3 Likes

I hope it is not one of those 32bit BIOS +64bit CPU system.

In that case, the installer must be modified with a shell script. And this script works only on some Ubuntu based distros and Zorin is not one of them.

The 32 bit download worked, but I can't get Rufus to find it and when I click the Zorin file to see what happens Windows says it can't be opened because the file is corrupted. Some savant needs to check the download file to make sure it's okay. But thanks for your help so far!

Please check sha256 checksum of the downloaded file.

Zorin OS 15.3 Lite 32-bit 95e4159ebb5b532932ade79cd0c439235e726dc30c8a00036820b7a96ee2f865

at this page:
https://passwordsgenerator.net/sha256-hash-generator/

The system I'm trying to download to is a 32 bit CompaqC60, about 12 years old. It's not home built and a pretty standard laptop running Windows 10 Pro (not home, because it came from a college discount program).

Not sure what you're asking me to do here-I inserted the numbers without title into the dialogue box and nothing happened when I pressed Enter

You can download any installer regardless of the laptop spec.
I was talking about the system you are planning to install Zorin 15.

Depends on the architecture of the tablet, it could be difficult if not impossible to install Zorin on it.

You have to grub and drop the downloaded zorin.iso file into the box to get the hash.
Then compare it to the correct hash I gave above to see if they match.

I tried to paste the iso file into the box, but nothing is happening.

The tablet I'm hoping to use it on is a Nextbook with an Intel Atom processor, 1gb ram and 1.33 ghz processor speed.

Antix, at best.

1 Like

After drop the file in the box, you need to press

Generate

button below the box.

1GB RAM would be problematic.
You could install Zorin on it, but how usable it is an another question.

I usually recommend minimum 2GB and preferably more than 4GB for Zorin Lite.

The perfect subject for the Lite profile, no?

The tablet is still working well with Windows 10, but it can't take any more updates and only has 5gb of drive remaining (out of 28 usable). But the problem isn't the tablet, I have to get the usable Zorin image onto my ample 32gb flash drive first

You are trying to install Zorin on 32 GB?
It could be done but how usable it is - I am not so sure.

I usually recommend 128 GB, 64 GB is minimum.

It just occurred to me.
Windows 10 is still under support.

I suspect your tablet cannot take any more update due to the lack of space. 5GB is not enough to take any update.

I saw many people purchasing Windows 10 laptops with 32 GB internal storage facing the same issue you are facing.