Zorin OS hangs in the installer and doesn't show partitions.

Well, I tried to install Zorin OS Core but I couldn't install it.

Well I have an nvme SSD and I've tried installing Kubuntu on my machine but it doesn't show correct partitions. Now I tried to install Zorin OS and it just crashes and doesn't come back, I waited hours and hours and nothing.

I've tried putting commands in the terminal and even commands at startup. I need help urgently!

Hello and welcome to the forum.
You might find the solution in this thread:

I wanted it to be my solution but it's not :frowning:

My case is different because the installer just crashes without responding anything else in a certain part of the installation

Specifics really are needed. Screenshots (Even using camera phone) can help a lot.
What commands have you tried? When you tried changing BIOS to RAID, did you remember to change it back to AHCI when that did not work?
What is your year, make and model of computer?

Well, I've tried using commands in the terminal and at startup and it doesn't solve it yet, as I'm a programming noob I don't remember what the commands were in my head.

But my biggest problem is that my bios is VERY limited for anything, because of Samsung. My notebook is Samsung X40 from 2018/2019, and in the bios there is no RAID option for ACHI or anything like that.

Yep, that would be the problem...

The following is a slight modification to the instructions from the other thread:
Boot the Live USB, then when you see the splash screen, start bapping at the esc key (instead of the e key.)
The way grub will look in this screen will be different from how it appears in terminal. Instead of moving to GRUB_CMDLINE_LINUX_DEFAULT, just scan the page for quiet splash and insert the text nvme_load=YES right after it, so it is quiet splash nvme_load=YES
Once this is done, hit ctrl+x to Exit this editor and proceed as normal. Do Not Reboot as the changes will not be saved between Boots. Then when you open the installer, it should be able to see the SSD.

3 Likes

You may want to write aravisian's suggestion down, specifically the nvme_load=YES... you will have to add it to your installed version as well.

Well, I tried the NVME_LOAD = YES option and it still didn't work.

In GPARTED appears almost the same in Windows but in the installer it crashes and no longer responds.

This looks a great deal like needing RAID set just as seen in another thread due to the nvme drive- but your ability to access that setting in BIOS is critical to correcting the problem.
I tried searching the issue for Samsung X40 and changing BIOS settings and did not find much... This Video Guide (In English) was offered up. I do not know if it will contain any information that helps you but may be worth watching to find out:
https://www.youtube.com/watch?v=l7SLkFSv-SI

I also found this guide for entering BIOS settings Samsung X40
https://www.youtube.com/watch?v=F0RFxvc1xFM

The worst part... in the bios there is no way to change RAID to AHCI. There are no options for almost anything...

Is the setting currently on RAID?

Is it possible to take a photo of your BIOS settings pages with a mobile phone? I am very curious to see it.

I remember that the original BIOS came with our old Acer Aspire had a notorious InSyde H2O and next to impossible to change anything. One reason I took a chance and flash it with a mod BIOS to remove those restrictions.

Here is a video I found on youtube that shows well the bios. Sorry for the delay and hope it helps this video. I'm actually testing going by the "Windows way" than trying to have another bios and being able to destroy my machine.

https://www.youtube.com/watch?v=D0VlzHoGzIU

I believe so but I can not say for sure because there is no way I see or change the configuration from RAID to AHCI or something like that.

I experienced a similar issue a couple of times. When the installer gives you the 3 check boxes (1. To install updates during installation 2. Download proprietary drives 3. Participate in the Zorin consensus.) make sure to uncheck the 2nd option to download proprietary drivers. Sounds a bit wild but I remember that causing the hanging issues for me.

2 Likes

I even go as far as untick the 1st option as well.
This way, losing the network connection would not affect the installation process.

1 Like

So I can flash bios?

If you are talking about updating BIOS to the latest version, sometimes it helps (but not always). As for the mod BIOS, I would not touch it unless you can get it from a trustworthy source - I was simply very lucky for that regard.

I updated my comment in the other thread you have started. Please read it.

I will try to install and uncheck these options but I think it will solve my problem :frowning: