PROBLEM: No Root File System is Defined

Hi - first timer here guys, trying to leave Windows for Linux.

I've got a 16gb flash drive and have, thus far, followed all the instructions on this page.

I get as far as installation, but it seems like it's literally trying to install FROM the flash drive, TO the flash drive. It's only showing one partition, which is 16gb... nothing at all about my internal hard drive, and no matter what I try (which granted, isn't much because I'm a newb) it keeps giving me the same error.

Would love some help here.

First thing, welcome to the community. As much as we love zorin, almost all the power users will tell you, don't use etcher. Rufus on windows or unetbootin on windows or Linux. If etcher hasn't ruined your flash drive, check the md5 checksum to ensure an uncorrupted image, then remake the usb with one of the other tools. Etcher causes many issues more than it ever does as it's designed.

Read up on the tutorials section of how to install... there are helpful recommendations that will make everything go smoothly.

Fast boot in Microsoft 10, fast boot and secure boot in bios all should be disabled... hibernation in windows should be disabled.... all of these are outlined in tutorials.

Changing partition size for windows disk, what partitions to make and recommended sizes are again all mentioned in tutorials category of this forum.

Try these steps and let us know how it goes.

1 Like

EDIT: Fully agree with Harvey that Etcher should be avoided at all costs. I use Unetbootin. Worth burning a new install on the USB with Unetbootin or Rufus before looking into the below.
/end EDIT

From your BIOS settings (Please look up a How-To guide based on your year, make and model from the manufacturer), ensure that your storage mode is Set to AHCI and not set to RAID. If set to RAID< this can cause the hdd to not be detectable.

Sadly, the only thing I can think of aside from that is that the HDD has armature damage or too many bad sectors. Windows operates by throwing down new data in any available space (Which is why you must defrag); but Linux allocates Set Blocks to properly contain data. These include extra space to account for growth (from updates) of installed software. No need to defrag Linux. If a piece of software outgrows its space, a new block is created and the entire file moved to that new block.
Too many bad or damaged sectors can cause this to be next to impossible, excluding the HDD from Linux. IF you happen to have a spare hdd layin' about, you could test this easily by switching them, then attempting (but not finishing) a Zorin OS installation.,


Thanks for this information!
It solved the mystery I encountered some years ago.

I bought an used laptop at Evile-bay which came with Windows pre-installed HDD (with much bad sectors). It worked fine in Windows but not in Linux. At the end, I took the HDD apart to extract yet another strong fridge magnets :wink:

That reminds me of a thing we used to do at work in the days of removeable hard disks the size of dinner plates. When one failed we pulled it apart and stuck the disk platter, often with a visible scratch, to the office wall. After a while it looked like the office band had won several gold discs - well bronze ones anyway :smiley:


My first dedicated word processor machine was running on 8 inch floppies. Makes me wonder which one of us is older? :rofl:

Dont get me talking about paper tape and punched cards :rofl:

My university had a computer centre which had a only air-conditioned room in the entire campus. The computer is so huge, it was occupying the entire room.

My assignment to write a programme in Fortran had to be given to a keypuncher. I remembered I failed several times. It is a kind of an indication that I am definitely lacking some sort of abstract thinking which is required for good programming :sweat_smile:

Just found this. It looks like floppies are not completely dead yet.

According to Tom Persky, a floppy disk expert quoted by the NYT, it’s surprisingly common to find floppy disks still in old industrial machines and medical devices.

Thanks for that!

I performed all the steps in this tutorial: Before you install

But, now when I restart and try to get into the bootloader to choose to boot from my USB drive, ESC, nor F12, nor Delete is working. It just boots straight to Windows.


Ok, so at this point, you have been able to see the Hard Drive in the Ubiquity installer in Try Zorin and got Zorin OS installed?

If so, at this point, you may need boot repair:

I don't think so... The failure to be able to opt to boot from flash drive seems to be directly related to the changes in Windows that I made while following the instructions of that tutorial I linked to.

Doesn't seem to be a problem with the flash drive. Seems like the computer is taking a default route (no pun intended) in selecting what to load at startup.

Ah, I misunderstood.

What year, make and model is your computer?

I can't remember the year. Just bought actually. ASUS Zenbook 15

Is this any help at all?

I suppose your secureboot (Windows only boot) is disabled?

Okay, so yes it helped. Thank you! However, I got to this point in the installation...

Yep. Followed Step 2 in this tutorial: Before you install

So... we are right back to where we started. The Ubiquity installer is not seeing your HDD or any partitions.
The traceback shows this, as well. First file could not activate new on partition, second could not locate target partition and third, no partition to create.
In your screenshots, it shows you on /dev/sda

You may ask, "But it works on Windows." Windows uses the first available slot, no matter the size, to write and it will fragment however much is needed just to be able to write. Because of this, you can be using Windows on a HDD completely unaware of the fault up to the very moment it finally gives out completely with no apparent warning. Leaves you saying, "Nooo... but... but... my data..."

I would encourage you to boot into Windows and use the Windows Partition Manager to isolate and create a Partition just for Zorin. Format it to ext4, not to NTFS. Then boot your USB and see if you can see that parition and hopefully, it was made where there are good blocks.
Otherwise, again, my own sad opinion is that the HDD is on its last legs and ready to give out.

  1. Thanks for sticking with me on this! :sweat_smile:

  2. I'll give the partition-from-in-Windows a whirl. Question: When installing Zorin there, will I ever be able to get rid of the remaining Windows partition completely?

  3. HDD can't possibly be on last legs, can it?? It literally arrived, brand new in box, yesterday.

You have a Point...
All I can tell you is that the complete inability to see the HDD is most commonly due to the HDD failing.
There are many possibilities: HDD is fine. HDD was damaged in transit. HDD was not as new as advertised... I don't know and cannot be very effective on exploring that over a forum...
It is possible that there are other unusual or rare factors causing your HDD to shield itself behind a Romulan cloaking field.

Yes; if that is your goal you could do that now assuming the HDD is good. You can choose "Erase disk and install Zorin".