Zorin OS Install Leads to Black Screen. HP Envy x360 laptop

I'm currently out of ideas on what to do next. I'm trying to install Zorin Pro onto a new HP Envy x360 laptop. I have only setup windows to the point where I can download new drivers and updates for the laptop. Whenever I try to install Zorin OS, either by clicking the normal download or safe graphics, I get a black screen after a few minutes. I have disabled secure boot, fast boot and bitlocker. I have also tried three different usb flash drives as well as using both balena etcher and rufus. Any ideas on what I am doing wrong?


HP Envy x360

AMD Ryzen 5 5625u

8GB Ram

This post suggests something simple:

I had the same problem but was able to get the live disk to load and install by adding "acpi=off spec_store_bypass_disable" to the grub command. Now it is working great

Thanks! How do I add that to the grub command? Sorry, am new to Linux

It's tricky with a LiveUSB, so nothing to be ashamed of there.

From the LiveUSB Grub Menu, you should be able to tap the e key to open the Editor for Grub.
Then look for the words quiet splash and add the grub parameters folling the word "splash" >
quiet splash acpi=off spec_store_bypass_disable
Exit the editor and proceed to boot...

Thank you! That worked for me and I was able to reach the desktop try or install Zorin screen. I noticed that my touchpad and touchscreen aren't working, but plugging in a mouse does work. Is there a driver I have to install?

Probably not... The Try Zorin falls back to generic drivers since the O.S. is not actually installed. This usually works fine, but on some hardware which needs to be recognized, it may cause them to not work.
Are you planning on installing Zorin OS?

Yeah I'm going to install it. If I'm understanding you correctly installing Zorin OS instead of using the demo mode will allow my touchpad to be recognized?

When installing, on the window that asks if you wish to install 3rd party drivers - ensure you click that box to mark it as yes.
Once install is completed, run sudo apt update && sudo apt dist-upgrade prior to rebooting and testing.
The latest kernel on Zorin OS is patched to include the HP Envy x360 touchpad (I checked quickly) so you really should have it working... but if not, please start a thread on it so we can try troubleshooting.

I was able to get pretty much to the end of the install until I got an error saying:

Unable to install GRUB in /dev/nvme0n1
Executing 'grub-install /dev/nvme0m1' failed.
This is a fatal error.

Should I just restart and try again?

This and Unrecognized Touchpad both can stem from Secure Boot being enabled in BIOS, but I thought I recall you had said that was disabled... Are you sure it is?

Yeah I had previously disabled it. Am I safe to reboot the laptop to double check?

Yes, you will have to reinstall but that is not a big deal.

Secure boot is still disabled, along with usb having priority in boot order

Can you boot LiveUSB Try Zorin, and launch Gparted and take a screenshot and post the partitions shown here?

EFI 512 boot partition.

Can you try running the installer and if grub fails - then run Grub Repair:

This is not your week for easy, is it?

Haha no it is not, although I don't mind troubleshooting. I ran the installer again and got the same error. Opened boot-repair through the terminal and when I click recommended repair I get an error saying:

/target detected. Please close the Zorin installer, then retry

What's weird is that the Zorin installer is closed, unless maybe it's detecting the USB ISO installer?

EDIT: I restarted it and tried to use bootloader without launching the Zorin installer application. I got past the /target error but got a new error stating

Error: NVram is locked (Zorin not found in efibootmgr).

Sounds a lot like this:

NVMe and eMMC have always been troublesome...

I checked the link and I don't think it matches my problem fully. When I initially clicked Install Zorin I opted to erase the drive and install Zorin since I wasn't planning on dual booting.

Gday @grizly Welcome to the community.

When you say you have windows, is that on this machine?
Do you wish to dual boot?
Sorry Im a little confused there. ( it doesn't take much to confuse me :slight_smile: ))

After installing have you removed the usb installer & reset BIOS to boot from drive?

Not sure if this helps,
I see in your "Gparted" photo, it doesn't show the column "Mount Point", The only way i could replicate this was to try Gparted while in Zorin OS "TRY" mode ( booting from usb installer into try mode shows no "Mount Point".) as per photo.
Making me think you still have the usb/Bios still at the installer.

where as on this machine & others i have all show the Mounting Point column.

If this is dual boot, was Secure boot enabled when you installed windows?
Is this a new machine purchased without an OS?