Zorin OS pro 16.3 installer NVME disk not detected.

I am trying to install Zorin os pro 16.3 on my DELL LAPTOP ( DELL inspiron 14, 5430).
But getting error that installer not able to detect PCIe M.0 NVME disk. Only my installation media which is bootable UBB disk is detected,

I have disable secure boot in BIOS and also disable fast boot option in Windos 11.

I have also tried by adding “nvme_load=YES” option in installer, but fail.

Seeking suggestion from this group.

Sachin Dhiman

I am no expert with Zorin or Linux. However, the newer the hardware including motherboard and processor, the more difficult it might be to get Zorin to work right since the kernel now is from April 2022, a few years ago. What is the age of the laptop? If really new, either Arch or Fedora might be better for you. Also, Debian 12 has the 6.1 kernel. Finally, the Ubuntu 22.04 LTS and interim releases have kernels now in the 6 range and above I think. Zorin is fantastic but the kernel is limiting unless you know how to upgrade the kernel. Zorin 17 might get released by the end of the year and will have a newer kernel but that’s several months away. Beyond my Linux abilities on how to upgrade the kernel before Zorin 17. Good luck.:+1:

Fedora is a nice distro, though it may not be as newbie friendly as Zorin, it does have a 6.x.x kernel.
From my system:

1 Like

You may need to enter BIOS and the SATA option, check RAID on(yes, normally, you will want AHCI...)

Then try running the installer to see if your nVME drive is recognized.


Fedora isn't hard i tried.
The first rules in linux world check on your own skin and taken experiences with tested distribution.
In the linux world we know are people who accept only on some forums they distributions (like a religions rules).
I liked Fedora because it have plenty spins desktop enviroments.
Never crashed for me when tested over 6 months.

Try raid mode in the bios, sounds weird but it was the only way for my dell netbooks emmc/nvme to be detected

1 Like

As you have purchased Zorin Pro, you could ask the Zorin Team for advice and help in installing. I am sure they can help.


my laptop is very new, purchased in june. This is Dell Inspiron 14.
issue is that Linux kernel is not loading nvme module.
i have tried to load nvme.ko file, which is available in bootable image, but not getting loaded.


i have purchased Zorin OS PRo, but since last one day there is no reply from Zorin OS team.
Hope that they will reply.


Have you tried the suggestion of switching to RAID as outlined above?

@Sachindhiman can you try the raid mode - as i have had success with it

@zorink @AZorin User is reporting difficulty/delay with Pro installation Support - any help will be appreciated

Pro support requests are in Linear Order and with two Zorin OS Developers; it's a matter of waiting in line sometimes.

1 Like

i am in touch with zorin pro suppport team, but they are responding in proper manner. they are giving standard solution like disable secure boot, disable fast boot. I already told them i have tried all these options.
For experiment to verify setting of BIOS and window, i am able to install Ubuntu 22.04.3 LTS on same laptop. It means what BIOS and window fast boot setting are in line with requirements.
But no proper responde from zorin OS support team. i was not expacting this.

To me, it seems completely expected.
They will start with the basics.
You saying, "I tried things" is a vague response. You have never answered me about whether you checked RAID settings in spite of me asking you about it twice.

Those trying to help you troubleshoot cannot telepathically know what you have done and tried. We cannot see your screen and into your computer.

Options you might try:

  • Create a Persistent Live USB version of Zorin OS 16.3. Upgrade the Linux Kernel on the LiveUSB persistent and reboot into it. Then run the Ubiquity installer to see if it recognizes your nVME drive.
  • Install Ubuntu 22.04 (Since it is known working) on the computer. Then LiveBoot Zorin OS and test if the nVME drive is recognized. If it is, it is due to a hardware setting, not the OS. It means that the hardware needed to be fully initialized once before it would allow detection.

It could be Zorin Pro don't support your hardware nvme disk or it have some secure things to installing Zorin Pro.
Sometimes Windows 11 don't liked together with unix operating system or something with bios. Difficult to know.
Did you checked webside https://linux-hardware.org/
Your laptop is from new century.

Always a good resource for new installs. Before you install

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.