Zorin OS Pro grub and kernel error

Hello everybody,
I purchased Zorin OS 16 Pro today after thinking about it for a few weeks and everything worked fine from the boot by usb until the system asked for a restart and removal of the usb used for booting. Basically the install was finished and needed a final restart for everything to work properly and to be able to save changes.

At this point instead of Zorin OS loading I get a page that looks like that:

GNU GRUB version 2.04

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.


When I enter the command boot the following error appears:
error: you need to load the kernel first.

In order to fix that I tried to use the article that was recommended on several other threads (https://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/ ).

However after I press on the button "Recommended repair" I get another error appearing that says that I can't repair before the first reboot from the usb. It has to be from the allocated drive if I understood correctly.

I would love some help to load the kernel and in general to be able to use my computer.

Thank you in advance for your help,
Kind regards,

1 Like

I finally managed to login to my desktop. however everytime I reboot or boot I first have to type in exit in the grub terminal that I described in the original message.

Anyone know how to make my computer boot normally?
Thanks in advance

When you type exit at the BusyBox screen, it should relay any error messages. Do you see any messages?

When I exit there are 5 options available:
Advanced options for zorin
memory test (memtest86+)
memory test (memtest86+, serial console 115200)
Zorin OS 16.1 (16) (on /dev/sdb5)

Can you take a picture with your phone or other and post here of that screen?

Here it is.

Odd... Usually using exit at the busybox error should print the initramfs errors - not load the grub menu...
Are you dual booting with another OS?
In BIOS / EFI settings, are you set to AHCI or RAID?
Is secure boot in BIOS disabled?

1 Like

No I used to have PopOS but now Zorin is the only OS running and I can't access BIOS / EFI anymore to change the boot order. F2 doesn't do anything anymore during boot.

I don't know if I am set to AHCI or RAID.

I haven't checked but I'm pretty sure secure boot is disabled.

When did this begin? Zorin OS would not cause that to happen, as Zorin does not alter any BIOS configurations.

It began yesterday just as I installed Zorin.

I don't think I did anything that could alter the BIOS though

1 Like

What about F12, F10 or F8?
Try tapping them vigorously when you see the Motherboard splash screen...

Nothing happens either with F12 F10 or F8.
I don't even see a motherboard splash screen anymore.
On one hand that worries me and on the other the computer kinda works properly so it'd just be a problem if/when I need to access BIOS in the future

Have you tried doing this using F2

Yes I have.

Sounds like Ultra Fast Boot is enabled, is this a desktop? Can try a few things
Depending on mobo brand

But try mashing esc or del on power up

Or reset the CMOS.

I know on gigabyte and msi the feature is called ultra fast boot, but it by passes checks and goes to the last uefi boot that's saved. Which sounds like it tries to boot popos off the drive which fails but because there is another grub instance you are able to fail out to the boot menu.

1 Like

It is indeed a desktop with MSI motherboard.
Thank you very much. I can now access the BIOS again. (with DEL
However I did check and the fast/ultra fast boot were disabled.
Is there any info that I can give you that would help you help me?

Try resetting the bios to defaults and reselecting your boot options / priorities

Same thing keeps on happening. Still need to type exit on grub.
I can access bios and the MSI logo appears on boot though.

Another option might be to perform a Fresh Reinstall of Zorin OS, if you have not been using it long and have all personal files backed up.


It seems to work now.
Thank you so much