Zorin OS Upgrader "internal error happened" when trying to update from 16 to 17.1 Core

I have been trying unsuccesfully to upgrade my system from 16.3 Core to 17.1 Core, everytime I attempt I get the error "Sorry, an internal error happened. The upgrader couldn't complete checking the upgrade requirements. Send an error to report to help fix this problem."
I have reported it multiple times, have updated my system and still not able to use the upgrader tool (I don't want to do a fresh install as I don't want to lose all my files"

Has anyone encounterd this issue and has anyone found a fix/workaround?

Thank you
Zorin Update Tool error

[CHECKING] Started
[CHECKING:Validating Upgrade Attempt] Started
[CHECKING:Validating Upgrade Attempt] Completed
[CHECKING:Checking Filesystem] Started
[CHECKING:Checking Filesystem] Completed
[CHECKING:Restarting Apt] Started
[CHECKING:Restarting Apt] Completed
[CHECKING:Simulating Flatpak Transaction] Started
[CHECKING:Simulating Flatpak Transaction] Completed
[CHECKING:Processing Apt Repos] Started
[CHECKING:Processing Apt Repos] Completed
[CHECKING:Updating Apt Repos] Started
[CHECKING:Updating Apt Repos] Retrying
[CHECKING:Updating Apt Repos] Completed
[CHECKING:Calculating Upgradeable Packages] Started
[CHECKING:Calculating Upgradeable Packages] Completed
[CHECKING:Simulating Apt Transaction] Started
[CHECKING:Simulating Apt Transaction] Fatal Error: { GDBus.Error:org.debian.apt.TransactionFailed: error-dep-resolution-failed: The following packages have unmet dependencies:

zorin-os-desktop: }
[CHECKING:Simulating Apt Transaction] Failed
[CHECKING:Restoring System] Started
[CHECKING:Restoring System] Completed

Running sudo apt -o Debug::pkgProblemResolver=yes dist-upgrade shows there are no packages with unmet dependencies

sudo apt -o Debug::pkgProblemResolver=yes dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Calculating upgrade... Done
Get more security updates through Ubuntu Pro with 'esm-apps' enabled:
libavformat58 libavfilter7 libmagickcore-6.q16-6-extra sntp imagemagick
libswresample3 libzmq5 libmagickwand-6.q16-6 libpostproc55 ntp
imagemagick-6.q16 libavcodec58 libavutil56 libswscale5 libopenexr24
libmysofa1 libmagickcore-6.q16-6 imagemagick-6-common
Learn more about Ubuntu Pro at Ubuntu Pro | Ubuntu
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Just found a similar post in "Installing Zorin OS", will post the link here in case anyne needs it, and will try to steps mentioned

Did you tried to reinstall the Zorin Desktop? You could use Synaptic or You open the Terminal and type sudo apt reinstall zorin-os-desktop

1 Like

I appreciate the suggestion, I had been using command line and it kept saying that zorin-os-desktop was not installed, I used Synaptic as you suggested (awesone tool) , tried to install it and evidently there are way too many broken packages, I may just perform a clean install and get it done and over with.

Thanks again,

1 Like