Zorin + RDP

First and foremost, I discovered Zorin a few weeks ago and I really, really, really, like what they're doing with the UI. I want to start using it every day.

However, most of my desktop use is through RDP. The problem is that when I log in via RDP, I get an XFCE desktop with some elements of the normal desktop (icons, etc.)

What do I need to do to be able to have that beautiful GUI enabled when using RDP?

Thanks all!

Welcome! :smile:

Looks like you're using the Lite version of Zorin, which is XFCE based. I'm not sure if you can install the Gnome environment to use on RDP - I know with XRDP, and vanilla Ubuntu, you can install extra DE's to use over RDP. But, since you're using Lite, only natural that it provides an XFCE environment.

I believe that the O.P. expects XFCE, but did not expect to see a Default Environment instead of the Zorin OS Lite Desktop.

1 Like

In your home directory (tap ctl+h if you need to reveal hidden system files), you should have a file named xsession
Can you open it and check if you have the line

echo "xfce4-session" > ~/.xsession

saved in that file? If not, copy and paste the above into the file. Then save the file.
Reboot and test RDP into the session.

Thanks. The file did not exist. I tried creating it and adding that line in it, but it did not work.

I do see other related files, like .xsession-errors or .xorgrdp.10.log.

Do you have the file /etc/xrdp/startwm.sh?
If yes, what is the output of

cat /etc/xrdp/startwm.sh

Yes, I can see that file and it has content in it.

user@zorin:~$ cat /etc/xrdp/startwm.sh 
# xrdp X session start script (c) 2015, 2017 mirabilos
# published under The MirOS Licence

if test -r /etc/profile; then
	. /etc/profile

if test -r /etc/default/locale; then
	. /etc/default/locale
	test -z "${LANG+x}" || export LANG
	test -z "${LANGUAGE+x}" || export LANGUAGE
	test -z "${LC_ADDRESS+x}" || export LC_ADDRESS
	test -z "${LC_ALL+x}" || export LC_ALL
	test -z "${LC_COLLATE+x}" || export LC_COLLATE
	test -z "${LC_CTYPE+x}" || export LC_CTYPE
	test -z "${LC_MEASUREMENT+x}" || export LC_MEASUREMENT
	test -z "${LC_MESSAGES+x}" || export LC_MESSAGES
	test -z "${LC_MONETARY+x}" || export LC_MONETARY
	test -z "${LC_NAME+x}" || export LC_NAME
	test -z "${LC_NUMERIC+x}" || export LC_NUMERIC
	test -z "${LC_PAPER+x}" || export LC_PAPER
	test -z "${LC_TELEPHONE+x}" || export LC_TELEPHONE
	test -z "${LC_TIME+x}" || export LC_TIME
	test -z "${LOCPATH+x}" || export LOCPATH

if test -r /etc/profile; then
	. /etc/profile

test -x /etc/X11/Xsession && exec /etc/X11/Xsession
exec /bin/sh /etc/X11/Xsession

Did you name yourself this... or are you running Zorin OS on the LiveUSB?

It looks like this is pointing to the default Xsession in Root.

Test the following:
Elevate to Root
Then modify that file like this:

# xrdp X session start script (c) 2015, 2017 mirabilos
# published under The MirOS Licence


You can leave everything below the line with startxfce4 as it is.

I did that to protect the innocent :smiley:

I added "startfce4" to the file and left everything else under it, rebooted, it didn't work :frowning:

1 Like

Ok let's remove that for now...

When you RDP, is the Desktop Wallpaper the Zorin OS Wallpaper or is it a generic wallpaper with a mouse on it or something?

Generic with a mouse.

I see some elements of Zorin's UI, like the File Manager is exactly like what I see inside Proxmox, but menus, etc. seem like they're coming from a stock XFCE desktop.

This makes me wonder if the RDP session is actually connecting to your User DE, but since some elements of the Zorin Desktop Lite are stored in root, it cannot access those.

Please elevate to root and copy the Zorin Default Wallpaper from /usr/share/backgrounds/zorin-mountain to your ~/Pictures directory. Change the files permissions to your user account (right click the file > properties > permissions)...

Logged into your desktop, open the display settings, change the source to your Pictures directory and select that wallpaper.
Save your Session.
You can do this in Session and Startup > General tab > Logout Settings > automatically save session on logout.

RDP in and check if the wallpaper is showing your selected wallpaper from the previous steps...

Looks like that worked. I basically selected a single image as background, closed the RDP session, and reopened it and the wallpaper was still there. This is what it looks like now:

1 Like

It looks like what the next step is is to setup your desktop emulating what the default Zorin OS desktop does in order to create these configurations in your User ~/.config directory.

Is there no other way? If I can install this differently or install Core or similar, I'm willing to do that. I have nothing important here that I cannot wipe.

This being said, I'm noticing this is an issue with a few distributions. Ubuntu, Xubuntu do the same thing I believe.

The options you suggested would be more work than right clicking the panel and selecting all your preferred options...

If there was a way I could think of - I would have recommended that method to give RDP root access. But I do not recommend giving it Root access.
So, reinstalling would just put you right back to square one.

Willing to try then. What do I have to do?

I am not sure. I have never used RDP and am not very familiar with it.

So, I will make generic suggestions that you can use as needed.

First, just as we did with the wallpaper, move a copy of your preferred Zorin Theme and Zorin Icon theme to home folder.
In Home, right click an open area and select create new folder.
Name it .themes. Repeat this and name the new folder .icons
Elevate to root and move to /usr/share/themes/zorin and navigate to your preferred theme. Copy it and paste it into ~/.themes. Give it your user permissions recursively.
Move to /usr/share/icons and select the Zorin Icon theme and copy it to ~/.icons. Give it your permissions recursively.

Right click the Top Panel and remove it.
Right click the bottom panel and move the arrow > panel > preferences
In the window select the (+) icon for new panel.
Now remove the old one using the drop down menu to select the existing wrong panel and click the (-).
For the new panel, check the box for it to be full length 100%.

I use Zorin OS Lite but I do not stick to the default Zorin themes or icons or setup... So I cannot remember all the details - but you can make note of default as it is located in /usr/share/xfce4/panel. You can do a copy paste and change permissions there, moving it to ~/.config/xfce4/panel OR:
Click on Items, and add - add Zorinmenulite. Then add docklike-plugin. Add a separator. Click the separator in the items list and click the Edit Icon. Set it to expand. Now add the rest of the listed items from the above /usr/share/.../panel directory.

The actual act shouldn't be as intense as the above sounds. I am trying to cover all the bases and be thorough.

Thanks, I will try this tomorrow and let you know how it goes.

I'm going to create a new Zorin Core instance in Proxmox and see how that looks and/or if it yields different results (although I don't think so). These machines won't hold anything critical or important for the time being, so I might as well try to RDP with root and see what happens.

I prefer RDP over VNC because I feel it is less laggy. Even though I run everything locally, I can feel the lag is bigger using VNC.

I appreciate your time to help me troubleshoot this!

1 Like

Firstly I admit I don't know much about RDP or VNC. However, all version of Zorin OS come with Remmina (Connect to remote desktop) installed. You should be able to sign in to your server/main computer using Remmina, which uses both RDP or VNC, without losing the Zorin Desktop. Just a suggestion.