Zorin Stucks on Restart, shutdown and Suspend

Everything was okay, but after some rip update it's very difficult to use zorin os Core without getting irritated to the point I shifted to windows.

Everytime I shut down Zorin Os. It stucks on black screen and doesn't turn off the device until power drains completely.

Similarly with restart, it doesn't restart but does the same when I click it stucks on black screen.

Same with suspend, after coming back and reusing the laptop thinking it would happen but nope it won't. A black screen stays forever where nothing works.

Please try booting from an earlier kernel like 5.11.0-44 and see of resume from suspend then works. If it does, the 5.11.0-46 kernel that came through a recent update may have regression.

1 Like

Did you disable power saving in the gpu settings ? What gpu do you have @Praveen ?

I don't have a external gpu, it's integrated radeon gpu and I don't remember anything about disabling gpu and where that option even is.

I tried every kernel version in zorin advanced option all are behaving same for me, I'm not sure what's the reason behind but I have a clue that I recently installed tlp but now I deleted it still the problem perisist. If anyone have any idea to fix please recommend.

Have you also tried kernel 5.15 and not the default ones that comes with Zorin?

I have no idea, How do I boot into 5.15 kernel.
The only I have tried which was in advanced option.

sudo add-apt-repository ppa:tuxinvader/lts-mainline -y
sudo apt update && sudo apt upgrade

First try with kernel 5.15

sudo apt-get install linux-generic-5.15

or the latest

sudo apt-get install linux-generic-5.16


1 Like

It is actually confirmed that kernels 5.13 on Ubuntu LTS (and thus on Zorin 16 too) DO have a regression.
It causes issues with reboots, power offs, hibernation and AMD SensorFusion Hub (on Ryzen-powered laptops, like my HP ENVY).

The issue is fixed, updated kernel is scheduled to be released by the end of January.

I confirm that using older kernel 5.11 continues working nicely, without issues.

Hi @Praveen ,
can you please post your HW specs?

@boldos Hi, It's very old laptop with 4gb ram and with AMD® E2-9000 radeon r2, 4 compute cores 2c+2g × 2

Anything more you need ?

I just wanted to confirm, whether you are using an AMD-based system, since these issues are especially seen on AMD-based laptops...
...although your system is not Ryzen, but built on older AMD technology, which is... interesting...
Anyway, thanks for the confirmation :slight_smile:

is there way to remove all updates and get back to the default one that comes with it zorin os cause it's so pretty much unusable now, also screen stucks randomly.. rip

Please try 5.16.
It is there :slight_smile:

ah, almost 600mb need to do this. I hope it fix this

Hello, this doesn't fix the issue unfortunately. I checked my kernal version it's 5.16 and tried restarting and it stucked with black screen...........
I have a update available hope it fixes the issue.

5.16 kernel version doesn't fix the issue for me sadly

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

sudo apt install linux-headers-5.11.0-43-generic linux-modules-5.11.0-43-generic linux-modules-extra-5.11.0-43-generic linux-image-5.11.0-43-generic

Hi, I tried 5.8.0-63-generic............
and it fixes the issue but when I reboot it gets back to 5.15 kernel
I did exactly what you shown in tutorial like boot into you desired kernel then change default=0 to default=save and also add new line then I saved it also did grub update then don't know it's still not my default kernel