Zorin17 non-native resolution issues

I just updated to Z17 and my laptop display is completely freaking out if I try to set it to anything but the native resolution. I'm still pretty new to linux in general so bear with me.
Asus Zephyrus G15, running 2 external 1080 displays, laptop display is 2k which makes scaling annoying, so I'm trying to set the laptop to 1080p which worked in Z16, which causes the issue.
I tried rebooting (duh), purging all nvidia drivers and reinstalling (then rebooting), and fractional scaling, all which don't help. I also tried setting Nvidia to always use the discrete GPU instead of integrated, which also didn't work.

Graphics info
description: VGA compatible controller
product: GA104M [GeForce RTX 3070 Mobile / Max-Q]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
logical name: /dev/fb0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=nvidia latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:fc0-fbf iomemory:fe0-fdf irq:121 memory:fb000000-fbffffff memory:fc00000000-fdffffffff memory:fe00000000-fe01ffffff ioport:e000(size=128) memory:fc000000-fc07ffff
description: VGA compatible controller
product: Cezanne
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:07:00.0
logical name: /dev/fb0
version: c4
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list fb
configuration: depth=32 driver=amdgpu latency=0 resolution=2560,1440
resources: iomemory:fe0-fdf iomemory:fe0-fdf irq:50 memory:fe10000000-fe1fffffff memory:fe20000000-fe201fffff ioport:c000(size=256) memory:fc500000-fc57ffff

Do you have Secure Boot enabled in your BIOS / EFI settings?

Which driver are you using with your Nvidia Card?
You can check using Software & Updates > Additional Drivers
I recommend the 545 driver on the later kernel for the Nvidia 3070 card,.

Is the monitor cable plugged into the ports on the back of the Nvidia card or into the ports on the Motherboard?

Secure boot is disabled.

I've tried 535 and 545, no change.

It's a laptop. The display that is having issues is the laptop's own display (15 inch 2k). The external displays (one plugged into the hdmi port, one through usb-c) have no issues since I'm not trying to change their resolution. I'll try changing the resolution on those to see what happens when I get the chance.

Have you used xrandr at any point to newmode and addmode any resolutions?

I have not. I'm purely using the built in zorin menu for changing the resolution.

Another update. If I run Z17 using the old kernel (5.15? it's the other option under advanced setting during boot) it doesn't create the issue. It only happens with the new kernel (6.5). Is there any reason I shouldn't just run using the old kernel?

None at all. If everything is working on it, it would be your recommended kernel.
You can also set that kernel as default boot:

That way if a later kernel includes a fix to your current kernel issues, you can just revert to using it later.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.