ZorinOS 16 Pro - Update Failure

First of all, sorry I've seen too many posts & forums on the same error but tbh none of them solved my issue. I hope this will help ^^

Description - I installed ZorinOS 16 Pro and I'm trying to update the system I am getting the error "Failed to Download repository Information" & sometimes "Failed to Download Package Information"

What I've tried: I've tried to change the Country server to the Main one and also tried changing it some of my regional ones, none of them worked.
My Wi-Fi is fully working so that's not a problem either.
I've tried the sudo apt get update command and I'll attach the screenshot of it's output :slight_smile:

I am stuck from last 3 Hours, any help is greatly appreciated :slight_smile:
Thanks in Advance!

Please run

sudo apt install --reinstall ca-certificates && sudo apt update

1 Like

Thank You so Much it worked!!
Forever grateful! <3

1 Like

I recommend remaining on "Main Server" in Software & Updates, by the way.


Sure, I'll switch. Thanks again!

1 Like

3 posts were split to a new topic: "Unable to lock" error, External Monitor blank

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.