ZorinOS boots in weird resolution

Hi guys, my zorin is boots in a weird aspect ratio. If I move my mouse to the edges of the screen, the display moves to look at a different part of the screen. This is only fixed by entering NVIDIA X Server settings, and applying my default resolution and refresh rate. Even setting it in the Gnome settings doesn't fix it. I am using an NVIDIA RTX 3070.

Hello Fazzi!

I am guessing your using the default Linux driver right now. What you want to go to is "Additional Drivers." And from there, switch to your proprietary Nvidia driver for your discrete GPU.

Picture to illustrate!

Once you select your proprietary Nvidia driver, restart the computer, and all should be good.

Ohhhh, and because "Additional Drivers" for some odd reason missreports my GPU, I took a screenshot of my Nvidia Xserver settings, to show I am not lieing lol.

BTW, congrats on owning a computer with a 3070! I got a 3080 in mine and I love these fast cards, as I am sure you love yours!

1 Like

Thank you for this! I'll test it out as soon as I can! And yes, I'm grateful for my RTX 3070. It's actually a Founders Edition model, that I purchased at MSRP. Don't fall to the Scalpers!


1 Like

WOW dude, a Founders Edition is a fancy card! And I am glad you didn't take a bight out of the fish scalpers game. Good for you! :+1: Yep, report back when you can and let us know how it went. Cool cool! :sunglasses:

Hey, it seems I already have the driver you selected installed on my machine. Any other thoughts on maybe how to do a clean install of the drivers?

OK, next I'd like you to enter your system "Settings Manager," and then go to "Displays." Please make sure that you don't have fractional scaling enabled, keep that disabled. And make sure scale is set to the lowest 100% just to be sure.

Do you know your displays resolution and refresh rate? If so, please make sure its set to the proper resolution and refresh rate of your display. "HiDPI Daemon" may or may not be causing issues, you'll have to play with that to see.

If the issue is still not solved, now I want you to go to accessibility in your settings. Please make sure that "ZOOM" is off. This is about all I can think of right now, hopefully we can get your system back on track for ya.

Hi, my Monitor is showing as "Unknown Display". The refresh rate option doesn't show up, and it doesn't allow me to change my resolution. Opening NVIDIA X SERVER SETTINGS shows this:
Running nvidia-smi in Terminal gives me this error:
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
I don't even know what's happening anymore. >.<


Your GPU is not being properly activated by the OS. Downgrade to the 460 driver, reboot after it's done, hopefully that fixes this mess. Sometimes the newest Nvidia drivers does not work and you have to use an older one.

I've just downgraded, then upgraded again. It's working again now. But now I'm getting the problem again. My system boots in the resolution 2304x1440. My real resolution is 2560x1440. I feel there is a config or something causing this but I don't know how I would find it.
I also still need to try and fix my mouse issue too.

edit: I think I may have found it. When I save my X Server config, it allows me to preview the file before saving. As you can see in the screenshot, for some odd reason it is setting my viewport out to the weird resolution of 2304x1440. I will edit it to 2560x1440 and see what happens.

1 Like

That fixed it! Now I just need to change the display scaling of GDM3 to 100% it is 200% I think so it looks very big.


Fixed this also!

You had a very strange and unique issue going on that I haven't come across before. But I figured you had a couple issues going on, which is why I gave you several pieces of advice. I am so glad you found the config, cause I am not sure that I would have thought of that. But the display scaling, that was the first thing I thought of.

Glad that I was able to help you somewhat, but at the end of the day, you were the one who actually fixed the issue you had. So that earned you browny points. Great job, and congrats!

Haha, great.

Here is the command(s) that actually fixed the issue.

Copy the monitor config to the GDM3 config folder
sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config/

Edit the file and set "scale" and "resolution" accordingly

sudo nano /var/lib/gdm3/.config/monitors.xml

1 Like

A post was split to a new topic: Nvidia-SMI failed on Zorin OS 16