17.1 battery life


I use the pro at home and the core for work.

I do the upgrade from 16 to 17.1 on my Lenovo P14s (work computer) and since the computer's fan turn everytime, loudly and extract very hot air. Before it's not the cas. And the worst is the battery life. Before it's not like with Windows (dual-boot) but it's was correct. Now I can use the laptop one hour max.

As you can see I have a CPU to 100%

Sometime it's CPU 6 or 8 or 5. But now I do nothing. This computer are amazing but why a CPU to 100%. I just do a post on Zorin forum now...

Do you have any idea of one solution or I have to format and reinstall the 16 ?

Thank to all.

Did you control the ''Process'' Tab if there are any Programs that could be responsible?

Yes, but... no. Nothing strange.

What is your output for

uname -r

and what is the make and model of the notebook computer?

Hi, Aravisian,


Lenovo ThinkPad P14s Gen 3
32,0 Gio
12th Gen Intel® Core™ i7-1280P × 20
NVIDIA Corporation / Mesa Intel® Graphics (ADL GT2)

I hope it's helpfull.

Can you please try upghrading to the 6.7 kernel and testing it (Secure Boot may need to be disabled in BIOS EFI settings):

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-generic-6.07

Reboot and test...


I add the first one wihtout problem but the second one have some error at for some package ''not installable''

But for now It's still the same after reboot. 30 min work and 30% battery out... And I just do mail via Ferdium. Before the upgrade it's not like this at all.

Just in case, since the upgrade I have this message with the session opening :

A falure to update some package... Maby it's help.

Thank again and have a nice day.

It's so strange. Before this upgrade the battery was full in 1hour max, now it's 2 or 3 needed and we never had 100% only 99%.

If I don't have solution this week end I format to but another distro for testing.

Did you upgrade from 16 to 17 with Zorin Upgrader? That may be the cause.

Agreed, Package failing to update and the kernel claiming to be uninstallable...
@Guillaume, please check your sources:

The upgrader may have left some Focal Sources listed.

1 Like

Okay strange...

I send you the source list but yes I do via the GUI and not via cmd.

# deb cdrom:[Zorin-OS 16.3 Core 64bit]/ focal main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://be.archive.ubuntu.com/ubuntu/ jammy main restricted
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://be.archive.ubuntu.com/ubuntu/ jammy-updates main restricted
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://be.archive.ubuntu.com/ubuntu/ jammy universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy universe
deb http://be.archive.ubuntu.com/ubuntu/ jammy-updates universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://be.archive.ubuntu.com/ubuntu/ jammy multiverse
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy multiverse
deb http://be.archive.ubuntu.com/ubuntu/ jammy-updates multiverse
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://be.archive.ubuntu.com/ubuntu/ jammy-backports universe multiverse main restricted
# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jammy partner
# deb-src http://archive.canonical.com/ubuntu jammy partner

deb http://security.ubuntu.com/ubuntu jammy-security main restricted
# deb-src http://security.ubuntu.com/ubuntu jammy-security main restricted
deb http://security.ubuntu.com/ubuntu jammy-security universe
# deb-src http://security.ubuntu.com/ubuntu jammy-security universe
deb http://security.ubuntu.com/ubuntu jammy-security multiverse
# deb-src http://security.ubuntu.com/ubuntu jammy-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

@Guillaume, please post the terminal output of

ls /etc/apt/sources.list.d


This one specifically says Focal

These may say Focal, still and the only way to know is to open the file and check.
You can elevate to Root:

sudo -i

Launch the GUI file manager from your elevated Root prompt:


Navigate to Other Locations > Computer > /etc/apt/sources.list.d folder and right click each file and check the name and contents, looking for Focal being present instead of Jammy.

You can see how this could be a problem since having two different sources with different dependencies can create conflicts or package deference.

1 Like

It is not the only One. There are two Others:

Yes, even though they are backup files, it shows a possible discrepancy.

Hi, thank for all your message.

So I change in every file ''jammy'' by ''focal''

When I try to update I get this :

But after a reboot it's different:

And when I do upgrade nothing change.

I still have this at startup and the fan very high everytime.

Maby I dont change correctly every list ?

Thank again.

For your sources, please see here:

The "Could not get a lock /var..." warning only means that you have another package manager open when you tried running the command in terminal. Package management only allows one lock at a time. Closing out the other manager is all that is needed to resolve that.

Number 8 the TuxInvader Repo is still focal. Number 12, 14, 15 and 16 too.

1 Like