Admin/ Main account No permission

lately I found that I can't rename or move some of my folders and day by day it's almost everything I'm nit sure what I did or what I was trying to do but now I have this message for all the folders

> " You are not the owner, so you cannot change these permission"

that makes me mad I tried to use sudo -i then nautilus but I got this


none of my partitions here it's not showing my HHD at all
also

I think the errors accessing the Trash and Desktop directories are expected when running Nautilus as the root user, since those two locations only exist for individual user accounts.

As for the permissions, can you double check the permissions and ownership? Run these two commands, one at the time, in a terminal:

ls -l $HOME
ls -ld $HOME

This should list the files in your user's home folder and the home folder itself. They should look something like this:

zenzen@zenzen:~$ ls -l $HOME
total 36
drwxr-xr-x 2 zenzen zenzen 4096 Apr  2 12:17 Desktop
drwxr-xr-x 2 zenzen zenzen 4096 Mar 12 07:30 Documents
drwxr-xr-x 3 zenzen zenzen 4096 Mar 25 18:05 Downloads
drwxr-xr-x 2 zenzen zenzen 4096 Mar 12 07:30 Music
drwxr-xr-x 3 zenzen zenzen 4096 Mar 24 07:06 Pictures
drwxr-xr-x 2 zenzen zenzen 4096 Mar 12 07:30 Public
drwx------ 4 zenzen zenzen 4096 Mar 29 08:28 snap
drwxr-xr-x 2 zenzen zenzen 4096 Mar 12 07:31 Templates
drwxr-xr-x 3 zenzen zenzen 4096 Mar 24 07:12 Videos
zenzen@zenzen:~$ ls -ld $HOME
drwxr-x--- 19 zenzen zenzen 4096 Mar 29 08:26 /home/zenzen
zenzen@zenzen:~$

The second and third columns are both assigned to "zenzen" which is of course my username. If everything looks good here, go into one of these folders until you run into issues renaming, moving, etc. and run these commands there as well.
For example, if you find a problem in Downloads:

ls -l $HOME/Downloads

If you find that the ownership doesn't match, run:

chown -R $USER:$USER $HOME/Downloads 

And as for the drive, can you see it listed in Nautilus with your user account?

1 Like

blackjokercore@blackjokercore-X750JB:~$ ls -l $HOME
total 36
drwxr-xr-x 2 blackjokercore blackjokercore 4096 мар 27 16:09 Desktop
-rwxrwxrwx 1 blackjokercore blackjokercore 282 мар 27 15:50 dimmer_startup.sh
drwxr-xr-x 2 blackjokercore blackjokercore 4096 мар 20 20:27 Documents
drwxr-xr-x 2 blackjokercore blackjokercore 4096 апр 1 21:06 Downloads
drwxr-xr-x 2 blackjokercore blackjokercore 4096 фев 14 12:27 Music
drwxr-xr-x 3 blackjokercore blackjokercore 4096 фев 28 15:56 Pictures
drwxr-xr-x 2 blackjokercore blackjokercore 4096 фев 14 12:27 Public
drwxr-xr-x 2 blackjokercore blackjokercore 4096 фев 14 12:27 Templates
drwxr-xr-x 2 blackjokercore blackjokercore 4096 фев 14 12:27 Videos
blackjokercore@blackjokercore-X750JB:~$ ls -ld $HOME
drwxr-x--- 21 blackjokercore blackjokercore 4096 мар 31 21:06 /home/blackjokercore
blackjokercore@blackjokercore-X750JB:~$
image

@zenzen as I found the problem with both partitions of the HDD I can't do anything in both partitions same thing for all folders

image
here example when I opened 1 of the partitions on Terminal and run

ls -l

when I tried
image

also FYI all folders in the HDD and files owner root
image

You need to add sudo at the beginning of the command, forgot to mention that:

sudo chown -R $USER /mnt/500GB

I did this

image

$USER is an environment variable that translates directly to your username; if you type echo $USER it should return "blackjokercore". So you can just use that as a placeholder for your username or you can type your username, that would work fine as well, but in that case you don't need the leading dollar sign.

So, this command:

sudo chown -R $USER /mnt/500GB

Would actually translate to this:

sudo chown -R blackjokercore /mnt/500GB

In my case that would be "zenzen", and so on.

@zenzen here we go mate
image

and still all the folders in the partition like this
image

If you try the same with some of the files or folders inside this location, does this work at all? For example:

sudo chown -R $USER /mnt/500GB/<some_file_or_folder_in_here>

I'm also curious if you have added an entry to /etc/fstab to mount this drive automatically? If not, we can try to unmount this drive and mount it again at another location.


here the mount options for the partition

Can you share your /etc/fstab? you can access it in terminal by cat /etc/fstab. It's probably permission related (was another system's drive at some time).

On the line above the mount point in the mount options, add a comma after Partition and include UID=1000,GID=1000. So it should look like:

nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=2nd%20Partition,UID=1000,GID=1000

This should give you write permission to the drive. I'd want to look at the fstab to confirm, as it may need the umask defined as well.

I suspect the issue is with the file system on that drive partition. Are you using this drive with other computers running Windows?
Zorin OS uses EXT4 as the file system whereas Windows uses NTFS. The way that file permissions are stored in EXT4 does not transfer to NTFS which would explain why the permissions are not taking in.

Run lsblk -f to list all block devices along with their file systems. Should return something like this (we're only interested in the second column of the drive):

NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda
└─sda1      ext4   1.0   PLAYGROUND  febc6cb7-142e-4ba7-b05e-7b0fea87c9b9  816.5G     6% /media/zenzen/PLAYGROUND

However, this still doesn't explain why you are seeing errors while renaming and moving files. Based on the permissions alone as shown in your screenshots this should've worked anyway.

So, does this maybe happen while you have some program running that is using the drive? Or are you maybe trying to drag files between drives? If you find that it sometimes works but sometimes it doesn't, please make a note of when the error happens.


@337harvey here

@zenzen yes mate on my HDD I have zorin lite OS
but it was normal before everything IDK
I thought about it also maybe the problem that I have another OS on the HDD

image

You need to provide the -f flag to see the file system as well: lsblk -f. If it's NTFS that would explain why you can't change the permissions on any of the folders.
Assuming that is the case, you'd have to narrow down when the issue regarding moving and renaming files happens, and when it doesn't. Based solely on permissions there shouldn't be any problem so there must be something else causing this. Maybe it's when you try with a specific file or while some process is reading its contents?


yes mate , can we solve this ?

I'm afraid this only explains why you couldn't change the ownership of the files, and not the reason behind the errors your were experiencing to begin with. As I said, try to narrow down when do these errors happen.

There's another thread where a user is seeing multiple folders for what should be the same drive location. I wonder if this is the same issue... for which we still don't know what is the cause or how to solve it. You might want to take a look, in case it sounds like this may be the case for you as well:


here is my Disks nothing bad at all

I agree, can't tell anything out of place from this. My only suggestion would be to try and find a pattern on when the issue happens. Perhaps something that was recently installed, updated, etc?

Also, all this time the assumption was that this issue happened only with files from an external drive; do you have any issues with files in your home folder, too?