Apps fail or slow to open

I installed Zorin Core on my MacBook Air (2012) because Ubuntu was very sluggish in opening and running apps. Things look good for it so I proceeded to load Zorin Pro on my MacBook Pro (2012). My problem is that this machine, with Zorin Pro, is also very sluggish to open apps, if they open at all. I can click on an app and I get a spinning circle for a short time and then nothing. If I keep at it the app eventually opens and then often it has multiple copies. Both machines have 8G mem. I expected performance to be as good as Apple? Any suggestions?

What i am thinking right now is temperatures. Did you clean the laptop in all these years ?


You have Pro (gnome) I believe. Have you tried Pro Lite (xfce) instead. If you purchased Pro, then that is included in the Pro package entitlement.

Yes I have.

Yes I did purchase Pro. How do I change to Pro Lite (xfce) and will it change much functionality?

I will create a new USB after re-formatting it and will give 'Lite' a go. It seems strange but the 'Files' app seems to be the worst of all apps. Failing to open or opening delayed with multiple versions after being clicked various times. I hope Lite works as I am getting tired of this distro hopping and just want set up/configured and then move forward. Thanks


Try KDE Neon after you try Lite

1 Like

I am trying Zorin Pro Lite and have what I feel is a dumb question but can't seem to figure it out. I installed Zorin Pro Lite and am doing configurations. I can not figure out how to make an app a favorite so it saves to my tray at the bottom of the screen. Regular Zorin I just need to hold the cursor on the icon and then select Favorite but on Lite nothing comes up to select? What am I doing wrong?

1 Like

Launch it -> right click while it is open on the panel -> left click “pin to dock”

I have clicked on all sides of my touch pad and nothing comes up to select.

In the linked pic, the settings are open and have a gear icon showing in the tray. Right click that icon (which corresponds to your application that is already launched and an active window)

I have done this over and over and nothing pops up with any selections. I even tried the old windows trick of rebooting. I tried multiple apps. I opened them and then clicked on their icon in the try and nothing. When I had Zorin Pro installed it seemed to work just fine but needed to downgrade(?) to lite.

Lite is not a downgrade. Just a different desktop environment (XFCE).
Can you post a screenshot of what you get when you right click the panel (taskbar) icon of any open application?

I opened Qownnotes and hovered on the icon and the little mini view of the larger screen pops up. If I click on the icon the Qownnotes screen minimizes.

I am glad to know Lite is not a downgrade. To me, Lite beer is certainly a downgrade from a real pint. lol

1 Like

So now, instead of left-clicking, you instead right-click on the icon. Any menu?

left, right. top. bottom...all same result, nothing

Can you try with a mouse connected instead of using your touchpad?

I don't have a separate mouse. Also it seemed to work just fine when I was on Pro. I installed Lite on Thurs/Fri this week.