Audio not working for HP Envy 17.3"

Im having trouble with my audio setup. I ran the following command to show you what I have in my computer:
cat /proc/asound/cards
0 [sofhdadsp ]: sof-hda-dsp - sof-hda-dsp

No audio is played... Not even in the settings when I ask for the audio to be tested... why is this? Audio works with headphones...

Brave GPT solution:

linux driver for sof-hda-dsp - sof-hda-dsp

To install the sof-hda-dsp driver on your Linux system, follow these steps:

  1. Update your system and install necessary packages:
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2
  1. Reinstall the sound-related packages:
sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2
  1. Restart the pulseaudio service, remove the pulseaudio configuration, and check the ubuntu support status:
killall pulseaudio
rm -r ~/.pulse*
ubuntu-support-status || ubuntu-security-status
  1. Add the current user to the pulse, audio, pulse-access, pulse-rt, and video groups:
usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

The sof-hda-dsp driver is part of the SOF Linux Driver Architecture, which is included in the Linux kernel. This driver handles the hardware interface for systems with the Intel Audio DSP, and it is located in the linux/sound/soc/sof/intel/cnl.c file. The generic SOF HD-Audio machine driver (skl_hda_dsp_generic.c) can handle any system that meets the following criteria:

  • Uses the Intel AZX HD Audio driver (linux/sound/pci/hda) when the Audio DSP is disabled (e.g., BIOS configuration)
  • Uses the Intel SST Audio driver (linux/sound/soc/intel/) when the Audio DSP is enabled

By following these steps, you should be able to install and configure the sof-hda-dsp driver on your Linux system.

Nope... didnt work....
Again... headphones work... This is a new computer... do you think it is a hardware problem maybe?

I did try to Google this a few hours ago, but did not post here because I don't have a solution. However, even I did not find a solution, this thread at Linux Mint forum might be interesting for you and/or others that want to try to help, as it is the same computer as you have and the same problem as you have.

The person have the exact same "HP-HPENVYLaptop17_cr0xxx-Type1ProductConfigId-8A2E". The thread is one year old. Only thing I can think of is that you make sure you have the newest kernel available. Are you on Zorin 17? Here is the thread:

I think it is a kernel issue. The sof software is made by Intel and gets incorporated into the linux kernel. I would suggest emit's advice and see if installing a newer kernel. @Aravisian for assistance on how to do that!

It says here that the laptop itself does not have a linux bios configuration...
Can this be fixed?

Yes, I am on Zorin 17 :slight_smile:

@Aravisian ... any thoughts on this?

I do not think it is likely that the kernel is the culprit.
Please install PulseAudioVolumeControl

sudo apt install pavucontrol

Once installed, reboot - test sound.
Then launch Pavucontrol from terminal with


Move to the Output Devices tab
Under the port drop down menu, relay what is listed.

@Aravisian, This is what I got... im confused as of why the hdmi ports are above the regular speakers... regardless... I have no idea what I should be looking at right now. What do you see?

Under Output Devices, click the drop down menu (Where it says HDMI/ Display port...) and see what other options are listed.

There are 3 HDMI displays listed... 1,2 and 3... each one has only one option in the dropdown corresponding to each number... The speaker+Headphones has 2 options... headphone and speaker... nothing else in the output devices....

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sofhdadsp [sof-hda-dsp], device 0: HDA Analog () []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 3: HDMI1 () []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*)
Subdevices: 0/1
Subdevice #0: subdevice #0

Maybe you need to fallback to default sound drivers.
Create new file:

sudo touch /etc/modprobe.d/inteldsp.conf

Access the file with text editor:

sudo nano /etc/modprobe.d/inteldsp.conf

Paste the below into the file:

options snd_intel_dspcfg dsp_driver=1

Tap ctl+o to overwrite the file, then enter to save current configuration. Tap ctl+x to exit the text editor.

Reboot and test.

closer? It seems like it wants to do something but no sound comes out...
take a look at those pics:

in the second pic, the dropdown shows a lot of options...
the weird thing is that the input device is not working now..
what is the next step @Aravisian ??

Can you please snap a screenshot or photo of the full drop down menu list?

It does show a lot of options...

The input is shown as unplugged - is this a timing thing?

After I applied that conf you sent me, the input just stopped working.

The /etc/modprobe.d/inteldsp.conf file can be removed using sudo if it is not working out.

Have you updated / installed Firmware for your device?