Black Screen appears and TTY is working

I am using Zorin OS 16, TTY is working, but the login screen is not showing. I have tried these:

  1. Sudo apt update
  2. Sudo apt upgrade
  3. Sudo apt --reinstall install gdm3

still the blackscreen with cursor blinking on left corner is showing.

We need some more info.

  1. Full computer specs

  2. Is it a fresh install with/without the updates?

  3. If Zorin worked before, what did you installed before the incident?

  1. SPEC:
    Processor: Intel i5-8250U
    RAM: 8GB
    GRAPHICS: Nvidia GeForce MX130

  2. No it is not a fresh install, I was using it since OCT 2021 and If we talk about updates then the system was updated.

  3. Last night I installed Java JDK-17, Jetbrains IntelliJ Idea, Pycharm, and Webstorm and use them for a while, and today when I started my pc, this black screen appear with no login screen nothing.

Do you recall any updates to the kernel or nvidia driver?

What happen if you in TTY type;


You could also try;

sudo ubuntu-drivers autoinstall
sudo reboot

Please Check this.

That's weird stuff going on....

Let's try;

sudo apt purge nvidia-*
sudo ubuntu-drivers autoinstall
sudo reboot


sudo systemctl start gdm3.service

No Changes at all still the same is happening.

sudo apt install nvidia-driver-390
sudo reboot
sudo systemctl start gdm3.service 
sudo service gdm3 start

If it doesn't work either, give me;

uname -a

Hello Sir, One more thing I want to add, everytime i reboot the system after the zorin logo animation complete, the black screen flashes atleast 2 times and then same problem happening.

Here is the Screenshot of above instructions:

Try uninstall the nvidia driver again and let the system fallback on the open source driver. See if it let you in then.

I'm wondering... could it be the kernel? Have you experience problems with kernel 5.13? To rule it out, please try kernel 5.11:

Sir, I have uninstalled the Nvidia, after the animation of Zorin is completed, the screen started flashing and the screen freezes with the HP logo & happens nothing.

Sorry, Sir, I don't have any option to downgrade or to boot from Kernel 5.11
Please check the Screenshot:

One more thing to add:
Sir, Till last night I had Zorin, 5.13.0-27.
Today morning when this problem happened and I tried reinstalling gdm3 the system got updated with this: Zorin, 5.13.0-28.

sudo apt install linux-headers-5.11.0-43-generic linux-modules-5.11.0-43-generic linux-modules-extra-5.11.0-43-generic linux-image-5.11.0-43-generic

Sir, I installed the kernel 5.11.0-43, after that,
I did this:

After this startx, some error occurred:

And finally, this message ends up:

What graphics card are you using?

Processor: Intel i5-8250U
GRAPHICS: Nvidia GeForce MX130


You might try

sudo nano /etc/default/grub

On the linux command default line, add nomodeset behind quiet splash so that it is "quiet splash nomodeset"
ctrl+x, then y key to say yes, then `enter key to save
Then run

sudo update-grub

and reboot and test...

Not working Sir, after typing startx Still showing : A problem has occurred and the system can't recover please logout and try again.

And if I am trying to open it with "sudo startx" then it is showing the login screen with root as user and none of password is working.

Can you tap esc or tab or left shift key to get to the Recovery Menu in grub.
Select Advanced Options for Zorin and then select Recovery Mode.
Arrow key down to enable networking and enable it. Back out to the recovery menu, arrow key down to Prompt
Hit enter
then run

sudo dpkg --configure -a

sudo apt --fix-broken install && sudo apt full-upgrade

Once complete, exit and try to boot normally.

No changes at all, same problem screen getting stuck at HP logo. (After Zorin boot animation complete) It is flashing and if I press ctrl+alt+F2-F6 I can access the TTY. From TTY if I am typing "startx" it is showing not found and if I again type "Sudo start" then it is letting me into Desktop but as root not as the user that I had registered before. But I am unable to log in as a normal user login screen, every time has to type "sudo starts" in TTY.

From the recovery mode under the root option if I do the same ( "sudo startx") it is showing an error as mentioned above in the thread number: 13.

Can you repeat the above, but this time enter in:

sudo apt install --reinstall zorin-os-desktop