Built-in audio of laptop not detected

I have recently got Zorin so I still do not know how things work yet, however, one thing I noticed is that my built-in audio does not seem to be detected. The sound settings only have the option "dummy output". Does anyone know how to fix this?

Welcome to the Forum!

When You have that dummy output: Did You tried it with a simple Restart and look if it still exists?

Did You tried to change from Wayland to Xorg? To do that, go to the Login Screen, click on Your Profile and when the Password Field is appeared You will see in the bottom right Corner a Gear Icon. Click On it and change to Zorin Desktop on Xorg, then Log in and test if the Sound will work.

Another Thing that You could try is use PulseAudio Control. It is a graphical Program for Sound Input/Output. To install it, open the terminal and type sudo apt install pavucontrol and then open it and look there in the Output and Configuration Tab.

Can you tell us what your machine is and also what sound card is in it?

If a Dell machine, there are past threads on the forum concerning "dummy output", including: Dell Precision 5750 - No sound ( Dummy Output )

Unfortunately, none of those have fixed the issue. The built-in speakers are still not showing up and still displays dummy output. But thanks for the suggestion.

If you can answer that question, it may then help us help you.

My laptop has an intel sound card. I have tried a few suggestions from that forum but still have yet to find one that works just yet. The snd_hda_intel value shows 0, which I do not know if that should be normal or not.

0 just means it is the first card detected.
Please open a terminal (Menu | Utilities | Terminal) and enter:

sudo lshw -C sound

and post back the results please.

In addition to posting result of:

sudo lshw -C sound

as asked by Swarf.


In terminal, can you open

alsamixer

Hit F6 to list sound cards alsamixer finds and post screenshot or type them here.

Did you just type "alsamixer"? I cannot see that command line from your screenshot.

I just did websearch using "Comet Lake PCH-LP cAVS Ubuntu 22.04". Found:

Suggests linux kernel 6.9 or later is needed.

I noticed from your hardware output the mention of 'sof' - this is to do with Intel Hardware and usually comes with the Linux kernel. So zabadabadoo's suggestion might solve the issue. It would be good if Zorin did what PCLOS does and provide 'sof' package.

Ok thanks, but my GNOME display is now refusing to work. I have tried to log in by doing crtl+alt+f1 but it keeps saying my credentials are wrong so I'm practically locked out right now. I can try to do a fresh install but with lite version so I have more free storage. I'll let you know if the problem can be fixed after a fresh install.