Cannot Boot From USB Stick

I recently bought 16.1 Pro and just cannot get it to boot from USB . . I've tried several suggestions . . turn off secure and fast boot . . boot with safe graphics option . . used different sticks both 2.0 and 3.0 . . even tried the boot from isofile on HD workaround, but got a bunch of error messages I'm not sure how to fix . .
FWIW, 16 works fine in VirtualBox . . Out of curiosity I also downloaded 15, no problems . . any assistance would be greatly appreciated.

Hi there,

How are you making the USB? I normally use Balena Etcher but I've seen in the forums that unetbootin is recommended instead as being more reliable.

1 Like

Did you download and have success with z15 32bit or 64bit?
Did you check the SHA256 checksum of your Z16 download iso?
See this :

1 Like

Thanks for your response . . I've used both Etcher & the Live USB Maker in my current OS (MX Linux) . . I'll give unetbootin a go.

1 Like

It was 64bit and I did verify the checksum.

1 Like

Thanks for that tip .... I just installed it .... hopefully I won't need it again ....

Update: Using unetbootin did get the OS to start, but it immediately drops to BusyBox initramfs and shows lot errors, mainly files/directories that couldn't be found . . downloaded a new copy of 16 pro, with the same result . .I noticed in both cases, unetbootin hung for a long time at the 74% (file 622) mark, if that's at all helpful . . I'm guessing from all this that the problem is in the iso and not with the USB sticks I've been using.

No guarantees, but try MultiSystem after you have formatted stick to FAT32 - needs to be 8 Gb minimum to try something like Zorin.
Get the package from the archived forum here:

My tutorial video on Vimeo here:

Or you could give rufus a try:

Thanks for the suggestions . . I couldn't get MultiSystem to recognize my drive even though I formatted it to fat 32 and mounted it to /media just as it asked . . as for Rufus, that's a Windows app and if I have to use a Windows app to burn a Linux distro, something's wrong. I've been working with Linux for 10+ years and have never come remotely close to having so much hassle with a distro . . I've contacted Zorin support as a last resort. I appreciate everyone's help, but unless 'home office' comes up with something, I'm done.

1 Like

Hi elwood66, Make sure that your USB is not being shown as UEFI USB - I can't use UEFI to boot off my MultiSystem USB it has to be just USB! That could be the issue - boot to BIOS, go to boot options and select USB [name of brand/etc] Mine's a 32 Gb Integral stick and is referred to as USB PMAP USB 2.0 but also has an UEFI entry!
Posted this using Manjaro on MultiSystem:

When I used unetbootin in the early days it started whirring for 20 minutes only to tell me that Zorin at that time was not supported. With MultiSystem it tells you straight away if it is not supported. You need to ensure that you allow GRUB to be installed to the memory stick, but again, disable UEFI while you are doing this generally - this could be the main cause of the memory stick issue. You can simply drag isos to the interface to build it on the stick.

Keep us updated.

I'm dealing with same issue. Only way I was able to load from mounted USB was going thru efi boot and manually selecting and it brought up the installation. I followed same procedures and nothing would automatically load USB. If you choose efi route have your partition ready as it won't detect other installed distros (had Ubuntu 20.04 installed).

Must say, I have been using MultiSystem for my thumbdrives since 15.3 with zero issues what so ever. It works perfectly. Like Swarfendor437 says it installed grub on the thumb drive so one can add as may iso's as liked. I also used to boot my Windows installation.
Further information for installation can be found here.

Just to add you can download a live version to DVD of MultiSystem that was based on Ubuntu 16.04:

Wasn't as done as I thought . . was able (with a brand new stick) to burn and install 16 Core . . then tried to burn 16 pro there with unetbootin, with the same bad result . . as for MultiSystem, got it working to the point of loading the iso, but then got an error message that I needed a different version of gtkdialog . . how much fun can one person have, eh? And now--icing on the cake--16 Core won't boot . . I'm back on my throughly dependable MX Linux OS . . Goodbye, Zorin.

Is a 4 gb drive enough memory on the thumb drive for pro install?

No, for the thumb drive, you will need at least twice that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.